The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Windows 10 and M-Audio 2626? Audio Interfaces
Old 14th December 2015
  #1
Lives for gear
 
Finnish's Avatar
 

Windows 10 and M-Audio 2626?

I know that 2626 is a legacy product on Windows 10, but anyone have any success stories with this combination?
Old 14th December 2015
  #2
Lives for gear
 
ChrisLudwig's Avatar
 

Quote:
Originally Posted by Finnish View Post
I know that 2626 is a legacy product on Windows 10, but anyone have any success stories with this combination?
Hi,
The last drivers for it are from 2013.
If and that is a big IF the drivers even install you will probably have to install the legacy windows 7 firewire driver to make it work. Even then it will be a roll of the dice if it works.

Chris
Old 14th December 2015
  #3
Gear Maniac
 

I have a 2626, running windows 10.
I didn't have to install any legacy firewire drivers.
Just downloaded the latest driver from M-Audio and it works fine.
Old 15th December 2015
  #4
Lives for gear
 
Finnish's Avatar
 

Quote:
Originally Posted by Manfriday View Post
I have a 2626, running windows 10.
I didn't have to install any legacy firewire drivers.
Just downloaded the latest driver from M-Audio and it works fine.
What's your FW-chipset?

Thanks
Old 17th December 2015
  #5
Gear Maniac
 

Im using a TI add-in card.
Old 17th December 2015
  #6
Lives for gear
 
Finnish's Avatar
 

Ok, thanks. I have a VIa-based desktop (worked flawlessly with win7) so we'll see..
Old 14th January 2016
  #7
Lives for gear
 
Finnish's Avatar
 

Yeah, everything works as it should, just tried it. Great!!!

edit: my firewire is
Code:
FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)

Last edited by Finnish; 14th January 2016 at 02:39 PM..
Old 3rd February 2017
  #8
RiF
Lives for gear
 
RiF's Avatar
Quote:
Originally Posted by Finnish View Post
Yeah, everything works as it should, just tried it. Great!!!
Is your Profire 2626 running fine on Windows 10?
I am on the fence to upgrading from Win 7 to 10, but I am not sure if everything runs OK.
Especially, I've read about problems with not being able to access all 26 i/o on the Profire. As I am using 24 analog i/o (added 2x Behringer ADA8000's via ADAT to the 2626), I am curious about this.
Old 25th August 2017
  #9
RiF
Lives for gear
 
RiF's Avatar
^ can anyone give some information about my question in the post above, please?
Old 25th August 2017
  #10
Lives for gear
 
Finnish's Avatar
 

It should work! I'm using only one ADA8000 but works just fine
Old 25th August 2017
  #11
RiF
Lives for gear
 
RiF's Avatar
Quote:
Originally Posted by Finnish View Post
It should work! I'm using only one ADA8000 but works just fine
Thanx! Can you please confirm that your DAW sees all 26 inputs? No need to have a second ADA8000 hooked up.
Old 25th August 2017
  #12
Lives for gear
 
Finnish's Avatar
 

My setup is far away right now so I'm not able to confirm right now. But, I'll try to remember that!
Old 25th August 2017
  #13
Lives for gear
 

M-Audio has current drivers up to Win 10 and a bunch of Mac versions. It should work fine.
Like all Firewire interfaces, you want to be sure your card has a TX Instruments Chipset.
Generic chips are known for having issues with dropouts and connectivity issues.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump