The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
My Ableton Live is lagging Audio Interfaces
Old 17th September 2015
  #1
Here for the gear
 

My Ableton Live is lagging

Hey everybody,

I'm new to ableton live and I use to use LPX. My issue is lag. While I'm in the creative process I have to wait a few seconds between tasks such as moving tracks around and editing certain tracks. It can get frustrating when its consistent and can kill the creative process. When I use to use LPX it ran very smoothly. I prefer to use ableton because of the features it has to offer. I just wish it ran smoothly and without lag. I recently updated my ableton from 32 bit to 64 bit hoping it would fix the problem and it seems to be running the same. Any suggestions?

I have a:
Macbook Pro (15inch, Early 2011)
Processor: 2 GHz Intel Core i7
Memory: 16 GB 1333 MHz DDR3
Harddrive: 250 GB Solid State SATA Drive

Software: Ableton 9.2.2 64 bit
Sample Rate: 44100
Buffer Size: 2048 Samples
CPU usage is at 12% on average

Interface: Apollo Twin Duo

Thanks
Old 18th September 2015
  #2
Lives for gear
 
ImNotDedyet's Avatar
You shouldn't need that big of a buffer size with that hardware IMO. That's damn big, especially for more live arranging. I'd try to go 256 or 128 even, if possible. That shouldn't kill your CPU.

All you have for hard drives is a 250 GB? An issue _may be_ the fact that the swap drive doesn't have enough space as you only have 256 GB of space for OS, programs, samples, recording, etc.
Old 18th September 2015
  #3
Gear Maniac
 

Make sure wi-fi is disabled when you open Ableton, that made a big difference for me.
Old 18th September 2015
  #4
Here for the gear
 

Thanks for the advice, Whats Hardware IMO?

I forgot to mention that I have a 1TB HD (Not SSD) in my lap top as well. The way I have it set up is as follows, My 1TB HD is where the original HD from stock was. The SSD is where the CD drive use to be. I use my SSD to run the OS, Ableton, and Ableton Sessions. The 1TB is where I keep my samples, music , etc. At one point I did run the sessions from the 1TB but I felt like the sessions didn't respond as quickly as when I ran them off the SSD.

Sometimes I feel like backing everything up into my externals and starting from scratch. I also thought of installing the original OS that came with the computer and using that. But I realized that my computer is running smoothly. Its really just ableton thats a bit laggy. What do you think?
Old 18th September 2015
  #5
Interesting... On live 8 I have a couple sessions that were weird. I would hit play and literally a whole bar later it would take to playback. These sessions were 20-25 tracks minimal plugs as well. Also, composing via midi was delayed by the same amount.

I tried the preferences menu under audio there is delay or latency shown depending on what sample buffer you choose. This did not help in these weird sessions.

The options menu at the top had a choice called delay compensation in these sessions this was checked (turned on). This was my issue.

I unchecked ( turned off) this option and playback as well as recording midi was not delayed.

Hope this helps
Old 18th September 2015
  #6
Here for the gear
 

This lag was happening to me too.

Make sure "Zoom Display" in preferences is at 100%.

There's a bug that in 9.2 that makes Live lag when it's anything other than default.

See if that works, before you reinstall anything!
Old 20th September 2015
  #7
Lives for gear
 
barryfell's Avatar
Slightly different Live lagging issue, but Live's play head not syncing with the audio when running with high latency plugins was always a huge pain when I used it. It was one of my reasons for moving.
Old 20th September 2015
  #8
Lives for gear
 
valis's Avatar
They have improved (but not 100% removed) the 'playhead' sync which is more a PDC related issue.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump