A&H GL2000 restore
Old 30th November 2006
  #1
Gear interested
 
LA1010's Avatar
 

Thread Starter
Question A&H GL2000 restore

I am restoring a 32 channel Allen & Heath GL2000, that apparently took a nasty lighting hit. I have it all playing except 4 channels (waiting on parts). When using the mixer, with all but 4 I/O channels, I am having problems with the whole board locking up as the op amps approach +/- rail voltages. Is this an inherent GL2000 design issue or is there another problem I should address? Any mods for this?

Last edited by LA1010; 30th November 2006 at 02:05 PM.. Reason: moving to proper thread
Post Reply

Welcome to Gearslutz Pro Audio Forum!

Registration benefits include:
  • Ability to make and reply to posts
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get instant lifetime access to the world's best private pro audio Classifieds for only USD $20
  • List your eBay auctions for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
andrewbob / Geekslutz forum
5
jeronimo / Music Computers
5
IGWright / Music Computers
4
Gie-Sound / Music Computers
0
grahluk / Geekslutz forum
0

Forum Jump
 
Register FAQ Search Today's Posts Mark Forums Read Search