The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
2i2 Problems -- Anyone Else?
Old 19th October 2013
  #1
Gear Head
 

2i2 Problems -- Anyone Else?

Sometimes my scarlett 2i2 suddenly stops working, I need to unplug and replug it to make it work again. I'm not really sure what causes the issue, and I honestly don't think it's about my DAW since it sometimes just stops working in windows (youtube etc). Basically, it's just random.

Anyone else havng problem with scarlett interfaces in a similar way? Maybe I'm missing out omething about Audio Interfaces in general..?
Old 20th October 2013
  #2
Gear Head
 

Go to device manager and in usb hub properties go to power management and uncheck "Allow the computer to turn off this device to save power"
Old 20th October 2013
  #3
Here for the gear
 

Quote:
Originally Posted by undream View Post
Sometimes my scarlett 2i2 suddenly stops working, I need to unplug and replug it to make it work again. I'm not really sure what causes the issue, and I honestly don't think it's about my DAW since it sometimes just stops working in windows (youtube etc). Basically, it's just random.

Anyone else havng problem with scarlett interfaces in a similar way? Maybe I'm missing out omething about Audio Interfaces in general..?
2i2 user here, usually it happens to me when i put the comp to sleep or hibernate and i wake it, the 2i2 doesnt like that. otherwise reinstall your drivers maybe?
Old 20th October 2013
  #4
Gear Maniac
 
jimi7777's Avatar
 

Try different drivers. The newest or recommended might not always be the best. Also try beta drivers (beta.focusrite.com), they somehow worked better for me.
Old 20th October 2013
  #5
Here for the gear
 

Used to happen to me all the time when I used the 2i2 with my Macbook Pro. No idea why, but I always had my System Preferences window open so I can easily switch back and forth between "Built In Output" and "Scarlett 2i2" to reset the settings.

I'm using a Mac Mini now as my music production computer and haven't had the problem show up at all. Have no idea why it used to happen all the time.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump