My Power Amp is making a scary noise!! Please Help! *SOUND CLIP*
Old 12th May 2013
Gear interested

Thread Starter
My Power Amp is making a scary noise!! Please Help! *SOUND CLIP*

I got a used Yamaha PD2500 Power Amplifier and its starting to make strange noises. It almost sounds like a fan without grease. One time I placed it on a different surface and that noise disappears. I play with a band a used this guy with some passive speakers. Recently the squeaking noise comes on just about 90% of the time.

I also connect it through a Xenyx mixer and today the sound just completely cuts off, I know it definitely has to do with the cable connection if not the XLR socket on the channels. Is there anything I can do? I wouldn't mind opening it up and taking a picture for you guys.

Here is the sound:

Thank you so much in advance.My band needs YOU to help us practice properly ><
Old 13th May 2013
Blast9's Avatar

Post Reply

Welcome to Gearslutz Pro Audio Forum!

Registration benefits include:
  • Ability to make and reply to posts
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get instant lifetime access to the world's best private pro audio Classifieds for only USD $20
  • List your eBay auctions for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Register FAQ Search Today's Posts Mark Forums Read Search