The No.1 Website for Pro Audio
Yamaha p2050 Amp - 1 ch needs high input to send audio out
Old 24th October 2019
  #1
Here for the gear
 

Yamaha p2050 Amp - 1 ch needs high input to send audio out

I wonder if anyone can suggest what MIGHT be the simple fix for my very old Yamaha p2050 Amp...

Basically 1 channel won't pass audio to it's output to the speaker unless I send a very high level to it's input.. and then it suddenly pops out the audio, sometimes a bit scratchy at first till I feed it a really high input level.

I flooded the volume dial with pot cleaner... made a slight improvement but not a full fix. THANKS for any tips!
Old 27th October 2019
  #2
Lives for gear
 
Pro Sound Guy's Avatar
 

Looking at some pics I can see you have switches and selector switches on the back of that amp. Make sure you exercise those back and forth many times in case oxidation is the issue. If you can pop the lid and get in there with some deoxit contact cleaner all the better.
Old 27th October 2019
  #3
Here for the gear
 

Thx, will do!
Old 4 weeks ago
  #4
Here for the gear
 

Hi well I flooded the back switches with pot cleaner and exercised them and that fixed it!!! Thx!!!!
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump