The No.1 Website for Pro Audio
iPadOS can read from and write to USB devices
View Poll Results: Is read/write access to USB storage devices useful to you?
Yes
6 Votes - 100.00%
No
0 Votes - 0%
Dunno
0 Votes - 0%
Voters: 6. You may not vote on this poll

Old 26th September 2019
  #1
Here for the gear
 

iPadOS can read from and write to USB devices

Hi,

just a heads-up. With the current updates to 13+ the OS for iPads migrated from iOS to iPadOS, so the forum name "iOS + Android Music + Audio Production Apps + Peripherals" needs an update. Now it's possible to use USB sticks and USB drives with an iPad, just an Apple, Linux, Microsoft or any other computer able to partition a device with a compatible file system is needed, assuming the drive shouldn't already be formatted with a compatible file system.

Apfs, hfs+, fat32 and exfat seem to be supported.

I successfully tested an Apple iPad Pro 12.9-inch, 3rd generation, 1TB, Wi-Fi, with a Toshiba disk, in a fantec DB-ALU3e enclosure, that is powered by it's own power supply, formatted by a Linux computer and connected with the iPad Pro by an Apple USB-C Digital AV Multiport Adapter, while the charging cable wasn't connected.

The USB enclosure and HDD are averaged, quite inexpensive parts. Likely a lot of us own several similar solutions, used as backup drives. I had no cheap adapter cable at hand, so I tested with an expensive adapter, that probably isn't required for this purpose.

Some CLI information about the iPad Pro and the USB drive, when connected with the Linux PC:
Code:
[[email protected] ~]$ ideviceinfo -u $(idevice_id -l)|grep -eClass -eModelN -eProductV|sed 's/ProductVersion/iPadOS/'
DeviceClass: iPad
ModelNumber: MTFR2
iPadOS: 13.1
[[email protected] ~]$ sudo smartctl -i /dev/sdf|grep Fam
Model Family:     Toshiba P300
[[email protected] ~]$ lsblk -oTYPE,NAME,PTTYPE,TRAN,VENDOR,MODEL|grep -eN -edf\ 
TYPE NAME    PTTYPE TRAN   VENDOR   MODEL
disk sdf     dos    usb    ASMT     TOSHIBA_HDWD110
[[email protected] ~]$ lsblk -oTYPE,NAME,FSTYPE,LABEL,SIZE,FSUSED,FSAVAIL,FSUSE%,PARTFLAGS|grep -eN -edf
TYPE NAME    FSTYPE  LABEL           SIZE FSUSED FSAVAIL FSUSE% PARTFLAGS
disk sdf                           931.5G                       
part ├─sdf1  ext4    u4.fantec     622.3G   287G  293.4G    47% 
part ├─sdf2  vfat    u4.fat32      103.3G    32K  103.3G     0% 
part ├─sdf3  exfat   u4.exfat      103.4G   3.8M  103.4G     0% 
part └─sdf4  hfsplus u4.hfs        102.6G 195.2M  102.4G     0%
That's what I tested, when the USB drive was connected to the iPad Pro:

After opening the File app and selecting "Browse", the "Location" widget does not show the ext4 partition, but it shows the fat32, exfat and hfs+ partitions, all by their label. Using lower case and a dot for the label of a fat32 partition might not work with Windows, but it does for Linux and iPadOS.

For testing purpose I selected "On My iPad" > "Auria Pro", the folder of a DAW app and then selected an audio project, chose "More" > "Copy" > "u4.fat32" > "Paste". No issue at all, so I continued by selecting "On My iPad" > "Auria Pro", selecting the same project, followed by "Move" to "u4.exfat", then creating a new folder and chose "Copy". This worked, too. At next I opened the Photos app, selected 2 photos, chose "Save to Files" > "u4.hfs" and "Save". It worked like a charm as well.

When finished I connected the drive to the Linux PC again, to take a deeper look at the partitions:
Code:
[[email protected] ~]$ ls -hAl /mnt/u4.{fat32,exfat/testfolder,hfs} 
/mnt/u4.exfat/testfolder:
total 256K
-rwxrwxrwx 1 root root 4.0K Sep 26 07:31 '._monomatch freeze.Project'
drwxrwxrwx 1 root root 128K Sep 26 07:31 'monomatch freeze.Project'

/mnt/u4.fat32:
total 96K
drwxr-xr-x 3 root root  32K Sep 26 10:58  .Spotlight-V100
-rwxr-xr-x 1 root root 4.0K Sep 26 11:20 '._monomatch freeze.Project'
drwxr-xr-x 6 root root  32K Sep 16 23:54 'monomatch freeze.Project'

/mnt/u4.hfs:
total 5.7M
dr-xr-xr-t 1 root root    2 Sep 26 03:28 '.HFS+ Private Directory Data'$'\r'
drwx------ 1  501  501    4 Sep 26 10:58  .Spotlight-V100
-rw-r--r-- 1  501  501 2.6M Sep 26 11:42  IMG_3100.HEIC
-rw-r--r-- 1  501  501 3.2M Sep 26 11:42  IMG_3101.HEIC
The hidden folders and hidden files were created by iPadOS. By this kind of file transfer, the HEIC pictures aren't automatically converted to a more common file format.
On Linux it's possible to convert the pictures by command line. Users who aren't comfortable with command line, maybe those who migrated from Windows to Linux, could use the cross-platform image editor GIMP. Most of the partitioning could be done without command line, using GParted. It can create the partition table, hfs+ partitions with a label and fat32 partitions with a label. Btw. if you try to name a fat32 partition "u4.fat32" with GParted, it automatically names it "U4FAT32". I named it by command line, with root privileges running "fatlabel /dev/sdXY LABEL".
GParted can't create an exfat partition, but it can create an unformatted partition. An unformatted partition can be formatted to exfat by command line, by running "mkfs.exfat -nLABEL /dev/sdXY" with root privileges.

Regards,
Ralf
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump