The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Api 2500 thrust detector not turning on Dynamics Processors (HW)
Old 13th February 2015
  #1
Gear Nut
 

Api 2500 thrust detector not turning on

Quick question..when I fire up my api 2500 the thrust detector doesnt automatically turn on...I have to wait about 30 seconds. And press the button 4 times then starts at the top and then it will start to cycle...is this normal???? Cheers
Old 13th February 2015
  #2
Gear Nut
 
InMyGalaxie's Avatar
 

Sounds odd. Should fire up all at once. I've had mine for a couple years and it's been great, although the "memorize settings" feature died recently. Easy fix, but too lazy to bother with it.

Last edited by InMyGalaxie; 13th February 2015 at 07:26 AM.. Reason: typo
Top Mentioned Products
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump