The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Lucid 88192 Won't boot up Digital Converters
Old 29th November 2017
  #1
Gear Head
Lucid 88192 Won't boot up

I replaced my lucid 88192 with a second Lynx Aurora about 5 months ago. Since then the Lucid has been sitting unused in a closet. I plugged it in last night and it powers up, but won't get past the lucid logo screen. It never fully boots up. There is a solid green led (I believe on the power supply board) that is lit, and I seem to remember there being a red light in there too, but I don't see it anywhere. It worked fine for years, but sitting for a few months seems to have broken it. Any suggestions?
Attached Thumbnails
Lucid 88192 Won't boot up-img_0048.jpg  
Old 5th February 2018
  #2
Here for the gear
 

i have a lynx ares16e with Lynx CBL-AES1604 into my lucid 88192 im not getting any signal input or output could you please help me ?
Old 16th September 2018
  #3
Gear Head
Bump

I know this is super old, but I’m still wondering.
Old 17th September 2018
  #4
Here for the gear
 

reset to factory
Old 16th December 2018
  #5
Lucid 88192

It can be the internal battery. It's like the size of a coin. Leave the Lucid on for two hours. Repeat this several times, a couple of days the battery may need to be rehabilitated.
regards
Old 2 weeks ago
  #6
Gear Head
Battery

Can you tell me where this battery is located? Im not spotting it in there. Ive tried the method you described with no success. If I can locate the battery I will try to replace it.
Old 1 week ago
  #7
Gear Head
No battery

Even though there is a sticker inside the unit telling what kind of battery to use, there actually is no battery or even a place to put one. I spoke to symetrix on the phone today, and the tech support guy had an 88192 there and couldn’t find a battery either. I even completely disassembled the whole thing and looked on the bottom of the boards. Nothing.

There is an orange light on the audio board that’s supposed to light up, but it does not. The power supply light works as it should.
Top Mentioned Products
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump