The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Universal Audio LA-610 ground hum
Old 14th June 2016
  #1
Gear Head
 

Universal Audio LA-610 ground hum

Hello guys!

I just bought LA-610 for 400$ with weard ground hum present only on xlr line input. When i connect xlr send from my DAW with mic input or hi-z jack input everything works great, but line in has terrible ground hum.

I opened the beast and noticed that mic input xlr ground is connected to the chasis, but not the line input xlr. So i soldered a jumper, connecting chasis and xlr line input ground and problem has dissapeared.

However i wonder if it's possible that UA has made such mistake in design, or i could have done something very stupid and could damage unit bu soldering that jumper.

Regards, Matya.
Old 14th June 2016
  #2
Gear Head
 

The question actually is, should ground of the XLR be connected to chassis, if not why would they want to have this connection on Mic In, but not Line In?

Anyone?
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump