The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Any Retro STA Level users who can help me?
Old 6th February 2016
  #1
Lives for gear
Any Retro STA Level users who can help me?

A very reputable, well known dealer has sent me a second hand Retro STA Level to demo with the view to buying - only one previous owner - it's about 18 months old and 40% cheaper than a new one.

So when it arrived yesterday it had been well packed but not in it's original box so that two of the valves (the OB2 regulator and the 12AX7) where loose in the box with bent pins - obviously forced off by the bubble wrap and foam peanuts in the box ..... slightly annoying.
It's a shame mainly because otherwise the unit is minty fresh - perfect not a single mark on it.

So my lovely wife, loving very carefully straightened the valve pins and I re-inserted them (the OB2 felt a bit loose so we slightly bent the pins out a touch and then it seated a little better)

I'm worried the valve sockets have been damaged by the force of the valves being forced out - although they look OK.

Also there's no manual and oddly on the Retro site I can't find a PDF manual.

Unfortunately when I turn on the unit it does nothing!
The mains light comes on the front but the meter stays deflected to the left and does move at all.

The unit is not passing any audio whatsoever.

I noticed at the back that the OB2 valve is not glowing - should it be?

Obviously I will call the dealer on Monday, I'm just frustrated because I had Sunday free to get some demoing done.

Any thing I might be doing stoopid?

Does anyone have a PDF manual for it?

Thanks
Old 6th February 2016
  #2
Lives for gear
 
ghostwriter's Avatar
I just checked mine and the OB2 is glowing, although not as brightly as the others.

Hopefully the dealer can send you another tube.

There isn't a Sta-Level manual.
Old 7th February 2016
  #3
Lives for gear
Quote:
Originally Posted by ghostwriter View Post
I just checked mine and the OB2 is glowing, although not as brightly as the others.

Hopefully the dealer can send you another tube.

There isn't a Sta-Level manual.
Thank you for your reply, I appreciate it.

Right, hopefully must be just the OB2 valve, Retro state on their site that nearly always operational issues are because of a value problem.

I'm surprised there's no manual .... for non technical users like myself.

There is a balance null button and a 6V6 biasing pot on the back that appear to be for the user to adjust?

It's so frustrating, I've waited ages to demo one and here it is sitting in front of me and it doesn't work. Doh.
Old 7th February 2016
  #4
Lives for gear
 
ghostwriter's Avatar
This thread might help explain those knobs.

Retro Sta Level not correct ballanced
Old 7th February 2016
  #5
Lives for gear
Perfect.

Thanks again
Old 7th February 2016
  #6
Gear Addict
 
wilkinswp's Avatar
 

Phil Moore at Retro is very helpful. He has helped me in the past with a 176 issue. I would give him a try. Alternatively, perhaps the dealer can assist.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump