The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Neve 1073lb doesn´t work in SM Pro Audio Juiceblock 3
Old 21st July 2015
  #1
Gear Nut
 
Freddie Flame's Avatar
 

Neve 1073lb doesn´t work in SM Pro Audio Juiceblock 3

I´m testing a Neve 1073lb for my SM Pro Audio Juiceblock 3.
My API 512c works fine in all slots.
The 1073 doesn´t.
Everythings looks fine on the input indicator and other LEDs.
But the output is minimal even when cranking both input and trim.

Read this in the 1073lb manual:
"Block (Issue 2 units only)
If present, these switches are On when in the Up position.
The left switch (Switch 1) should be set to On when the module is to be used in a non-API Lunchbox housing that does not have the same earthing arrangement as the Lunchbox. This is factory-set to Off.
Failure to set this switch correctly will mean the phantom power will not work, plus other operational inconsistencies."

I have the older Issue 1, without this switch. Is this the problem?
Or is the 1073 simply broken?
Old 22nd July 2015
  #2
Gear Maniac
 

Not enough juice?
Old 22nd July 2015
  #3
Lives for gear
 
Oldone's Avatar
Possibly the juice is being blocked.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump