The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
What could be wrong with this old effects box? Analog Processors (HW)
Old 15th September 2011
  #1
Registered User
 

What could be wrong with this old effects box?

I have a Yamaha Rex 50 multi-effects unit that I've used for a while. Just recently, it seems to have gotten a little bit screwed up. Whatever signal is going through it comes out thin, fuzzy and distorted and the output is very low, making it pretty much unusable. You can still hear the sound and whatever effect is selected, but the low output and distortion is still there.

Any ideas? The unit is Japanese, straight from the eighties, and of course all digital. I opened it up but couldn't see any disconnected wires or anything of the sort. But there aren't even many wires to begin with! Is there any chance it's an issue with the power transformer?

Any guidance would be greatly, greatly appreciated.
Old 15th September 2011
  #2
did you check the solder pads at the output jack for "cold solder joints" or loose solder joints?

while the guts are out you might as well check the other solder pads to.
Top Mentioned Products
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump