The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Is my power amps broken? Please help diagnose!
Old 7th September 2011
  #1
Here for the gear
 

Is my power amps broken? Please help diagnose!

Hi,

One side of my amps racked in my PA system is broken (i think)

When I put signal through it (a vocal) the output from the amp is very low and cuts in and out. If i shout and put lots of signal through, it suddenly leaps into life and sounds normal, but only for a couple of seconds and then dies down again.

It's seems if you put lots of signal through it, it almost kicks into action. If you put a normal amount through, the sound it puts out is crackly and very quiet?

Please help!!!!
Old 7th September 2011
  #2
Probably a bad contact on a strip connector, or bad potentiometer.
Old 7th September 2011
  #3
Here for the gear
 

hmmm.

i've tried using different channels on my desk. all other amps and graphics etc and have isolated he problem to either the output from my graphic eq, the input to the left side of my amp or the amp itself.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump