The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Probably simple problem with an Ibanez SD-9 pedal Effects Pedals, Units & Accessories
Old 1st September 2011
  #1
Here for the gear
 
Getmad24_7's Avatar
 

Probably simple problem with an Ibanez SD-9 pedal

Hi,
I have an Ibanez SD-9, and it's been working fine for the last year, although this problem has occured before, and was fixed simply by taking the back cover off the pedal and putting it back on. It turns on when power is connected, and won't turn off. In addition, the sound quality is significantly quieter and worse. How can I fix this ?
Top Mentioned Products
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump