The No.1 Website for Pro Audio
Did I fry my interface? Please help
Old 12th August 2020
  #1
Here for the gear
 

Did I fry my interface? Please help

I have a Behringer UMC404. Accidentally plugged the wrong power cable into it while rearranging my desk. I immediately unplugged it but it seems that was all it took.

Now, when I plug the USB cable in, the power light comes on but the computer doesn't recognize it. The clip and signal lights come on periodically and it makes a popping noise then goes dark again (the power light stays on).

I'm obviously a total rookie when it comes to the electrical side of things, but I took it apart to see if there was any obvious damage and everything looked fine. Tried different USB cables. Tried reinstalling drivers.

Does anyone have experience with this? I just got this interface and was a huge upgrade from my old one so I'm really distressed and open to any suggestions. Thanks for reading.
Old 12th August 2020
  #2
Here for the gear
 

Quote:
Originally Posted by Anonimiss View Post
I have a Behringer UMC404. Accidentally plugged the wrong power cable into it while rearranging my desk. I immediately unplugged it but it seems that was all it took.

Now, when I plug the USB cable in, the power light comes on but the computer doesn't recognize it. The clip and signal lights come on periodically and it makes a popping noise then goes dark again (the power light stays on).

I'm obviously a total rookie when it comes to the electrical side of things, but I took it apart to see if there was any obvious damage and everything looked fine. Tried different USB cables. Tried reinstalling drivers.

Does anyone have experience with this? I just got this interface and was a huge upgrade from my old one so I'm really distressed and open to any suggestions. Thanks for reading.
Hi Anonimiss,

Joe here from Behringer support - unfortunately this does sound like there's an issue with your interface. Maybe try connecting it to another computer via USB just to be sure.

Failing this, please contact us via our Care Portal to discuss this further.

https://community.musictribe.com/pages/care-portal
📝 Reply
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump