The No.1 Website for Pro Audio
Help woth a glitching Eventide H949 Harmonizer
Old 25th May 2020
  #1
Help woth a glitching Eventide H949 Harmonizer

Hi I have an h949 I got fairly cheap ($850). The seller said the “master” pot was a little dirty and needed to simply be cleaned. He lied. There’s a serious issue affecting the lcd readout:

The display is displaying the numbers erratically. They move it erratically with the “master” knob when it is turned. When you leave it alone it sits on whatever number it landed on however when you turn the pot it skips around Numbers pretty wildly. I figured the pot went bad so replaced the 10k pot however the same issue persists. Any ideas what could be glitching here? Could a failing resistor somewhere be the culprit? I’m no EE so I’m not trained to use an ESR meter or oscilloscope and reeeeally would love to hear there’s a known issue here or something I can do to avoid a tech if possible.

Thanks in advance
📝 Reply
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
♾️ Similar Threads
🎙️ View mentioned gear