The No.1 Website for Pro Audio
Audio interface 1 bad (low input) channel
Old 3rd December 2019
  #1
Gear Head
Audio interface 1 bad (low input) channel

Hi

I have a Scarlet 18i20 audio interface that is working well with the exception of one audio input (CH 3).
it does detect the incoming audio signal but only enough to light the first led segment, barely audible. Adjusting the gain on that channel seems to do nothing to increase the volume
I've had it for a few years (out of warranty) it was working well, until it wasnt... All the other channels seem to work OK

Does anyone have any hints on what I should check out first? I was thinking to try and replace the OP Amp on CH 3, is that a good start? or should I be looking at Caps etc?

I'm OK with a soldering iron and have done quite a few basic repairs on old gear before, but I don't have much technical knowledge on circuits.

Anyway if anyone had any thoughts, I'm all ears.

Thanks
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump