The No.1 Website for Pro Audio
Ground Loop Issue - PM-1000 - Any ideas?
Old 6 days ago
  #1
Ground Loop Issue - PM-1000 - Any ideas?

Hey slutz,

I recently overhauled a PM-1000 by recapping and installing transformer direct outputs on each channel. The direct outs are wired up by DB25 connector and I have the ground connecting to the chassis. Sometimes, I want to use compression on the way in, so I route the necessary channel to one of the monitor outputs. On all of the monitor outputs, there is a ground hum.

Do any of you guys that are way smarter than me have any ideas where this could be coming from? Could it be the ground from the DB25 connected to the chassis?

Thanks in advance!
Old 6 days ago
  #2
Lives for gear
Check your other outputs.
Any hum on the main outputs?
Any hum in the direct outs?

Did you recap the master sections as well? Maybe there is a poor connection to ground that needs to be reflowed somewhere around the monitor outs section.
Try disconnecting the ground on the db25 and see if it’s any better.

Maybe there is a better place to attach the ground.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump