The No.1 Website for Pro Audio
How to Bias Ibanez TSA15H
Old 1st December 2018
  #1
Here for the gear
 

How to Bias Ibanez TSA15H

Can someone tell me how to bias a Ibanez TSA15H amp with a multimeter? Itb as 2 - 6V6GT tubes. I had to replace the bias trim pot. I know it needs to be bias'ed at -30v from what Ibanez told me.

Test points are at PR1 & PR2
Attached Thumbnails
How to Bias Ibanez TSA15H-dsc01486.jpg  

Last edited by Robert Machine; 1st December 2018 at 03:56 AM.. Reason: Added info
Old 1st December 2018
  #2
Here for the gear
 

I found some info that the test points on this amp are at PR1 & PR2 right by the bias pot. I get voltage at PR1 that reads -30V but PR2 has 0.00.

One tube lights up in both sockets but the 2nd tube does not & has some white particles. Also I get 0.00 reading on PR2 when the tube that lights up is in either socket. I know both tube lit before changing the trim pot. Is it possible to do any trouble shooting? I don't wanna waste $40 + on new tubes just to be disappointed.
Old 1st December 2018
  #3
Lives for gear
 
Radardoug's Avatar
 

The voltages in that amp can kill you if you dont know what you are doing, and you dont sound like you know what you are doing. There is plenty of info on guitar amps out there, if you really want to learn then study study study!
Old 2nd December 2018
  #4
Here for the gear
 

Quote:
Originally Posted by Radardoug View Post
The voltages in that amp can kill you if you dont know what you are doing, and you dont sound like you know what you are doing. There is plenty of info on guitar amps out there, if you really want to learn then study study study!
I am aware of that, & I worked with one hand behind my back. I put my ground lead on my multimeter to the amp chassis & the positive lead to test points "PR1" & "PR2" I'm getting -30v on PR1 & 0.00v on PR2. I also tested pin 5 & 7 with the power on in standby & got -30v on tube 1 & -30.2v on tube 2. On closer inspection my one power tube has a u shaped crack & I believe that is why it is no longer glowing due to a ignorant tech I traveled 4hrs round trip to bias this amp & when he tried he found I had a bad bias pot & wanted $100 to replace it & bias the amp. I was not paying him that nor traveling another 4hrs to pick it up, when I know how to put in a new B50K bias trim pot & drain the caps. I know my power tubes were good cause I had them tested the day before at another shop but they did not have any 6V6GT. So out of spite this tech cracked my tube.

You are correct I'm not sure how to bias an amp hence the reason I'm asking. I've researched how to do it & no one says how to on this amp. I know the formula PV/PC/PD for bias'ing & I'm trying not to kill myself, so your comment isn't very helpful but thanks!

Instead of saying study, study, study, it would be more helpful to share some knowledge & share some links, as I know some stuff about electronics but not enough to know a lot of other stuff & the misinformation on this amp is unbelievable! After all that's what these kind of forums are for... Right?
Old 2nd December 2018
  #5
Lives for gear
 
Radardoug's Avatar
 

Find yourself a primer on valve amplifier design. Its not rocket science.
Like this one.
How To Bias Tube Amplifiers - ampvalves.co.uk
He suggests you buy the bias probe, probably a good idea if you are going to do this a lot.
Also, good data sheets will give you typical valve conditions. Its not that big an issue, valves are quite forgiving. If you have 30 volts bias on both tubes you wont be far out. But a broken tube will never work. And guitar amps are not exactly hifi. Stop worrying and start playing.
Old 3rd December 2018
  #6
Here for the gear
 

Thanks, I was just looking for one of the probes to measure PV. I replaced the trim pot in my Ibanez TSA that's why I need to bias this amp. While am learning I'd like to find out if the Marshall Origin 50 has a bias trim pot. If it does I'll spring for the $120 meter.
Old 8th August 2020
  #7
Here for the gear
 

Un son très sympa. Pas loin du Blues Junior dans la dynamique.

Par contre, attention avec le TSA15 d'occaze. Certaines séries ont un gros souci électronique. Il faut le tester un bon 1/4 d'heure pour voir si le son ne se coupe pas.

À regarder un peu sur la toile. C'est une panne récurrente sur certaines séries qui apparaît quand l'ampli chauffe. Et bien, il se met en sécurité et se coupe littéralement, click site. Après, il faut attendre qu'il refroidisse.
📝 Reply
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump