Voyager grounding issues
Old 16th March 2013
  #1
Gear nut
 

Thread Starter
Voyager grounding issues

So I finally bought this amazing Voyager EB (early versions I think), but I am having some issues.

I found that no matter to which power outlet in my house I connect it to,
when I touch the chassis screws, I get some kind of a light electric shock.

I had the same problem with my Little Phatty when I got it, and the solution suggested by moog was to add a wire between one of the ground leads going to the power supply, and the metal chassis (this solved the problem on the LP).

I wonder if this is a known issue and how can it be solved in the Voyager :/

Thanks !
Topic:
Post Reply

Welcome to Gearslutz Pro Audio Forum!

Registration benefits include:
  • Ability to make and reply to posts
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get instant lifetime access to the world's best private pro audio Classifieds for only USD $20
  • List your eBay auctions for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
Mystic Muse / So much gear, so little time!
11
hociman / So much gear, so little time!
9
AlexLakis / So much gear, so little time!
6
neon / So much gear, so little time!
14
matt thomas / So much gear, so little time!
3

Forum Jump
 
Register FAQ Search Today's Posts Mark Forums Read Search