The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Synths for sale  Search Gearslutz Go Advanced
ASR-10 only turns on for a split second - bad PSU?
Old 19th June 2017
  #1
Here for the gear
 

Thread Starter
ASR-10 only turns on for a split second - bad PSU?

Hi y'all

First of all, I hope I'm at the right place (if not, please move).

So I've been offered this ASR where the owner claimed everything used to work perfectly fine until recently, but now, the unit does actually power on, but turns itself back off after only a few moments. There's also an audible hum.

Do y'all think it's safe(-ish) to pull the trigger and expect to only put minor work into it (checking fuses, recapping or maybe replacing the whole PSU board), or do you think I need a complete recap or something?

Also, does anyone have experience with repairing these things? Before y'all suggest me to: Taking it to a repair-center is NOT an option, not only can't I justify spending that much more on the parts, I also can't really take it there.

Thanks for your suggestions!

Cheers
Old 19th June 2017
  #2
Lives for gear
 

Here's my perspective: let's say the power supply is the problem (sounds reasonable anyway).

Now you fix or replace the power supply, and it powers on, but in the process of the power supply going out, it also took out one or more of the boards and or ICs...

Now you're going to be troubleshooting that problem... Not knowing your skill level but I know my limits, and I don't really want to pay someone to fix it..

Knowing that ASR10s can sometimes have problems (and even just going by age alone), I do consider the suggested scenario realistic. Sure it's possible that a power supply alone could get you running no problems...but it's a gamble. So if you're going to gamble, how much are you willing to bet, and how much can you afford to lose if you have to scrap it?

When it comes to buying broken gear (which I have done a LOT of), if I can't get the thing fully powered on to fully see what's going on, I'm going to pay junkyard value only. By that I mean $20-75 probably, depending on what it is and if I know for sure I can fix it, or if my last resort tech will be able fix it.

I have 4 ASR10s right now (2 scrap), the working ones I found for around $150-200 each so I wouldn't pay a lot for a dead one.
Old 19th June 2017
  #3
Here for the gear
 

Thread Starter
thanks for you input!

I decided to pull the trigger, a functioning SCSI board alone is worth more than what I paid for my unit.

Will update if there is any progress.
Old 19th June 2017
  #4
Lives for gear
 

Quote:
Originally Posted by JulianUndso View Post
thanks for you input!

I decided to pull the trigger, a functioning SCSI board alone is worth more than what I paid for my unit.

Will update if there is any progress.
Best of luck, but I guess I was trying to say it's tough to gauge what is and is not working if you can't power it on to test it...no way of knowing if that scsi board is still alive until you get the whole thing going.
Old 20th June 2017
  #5
Gear Addict
 

Just putting it out there: I have an ESQ-1 that had the same symptoms. I pulled every single connector and cleaned both ends with deoxit, and it totally fixed the problem (for now at least). You may try that. Could fix your problem.
Mentioned Products
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump