The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Synths for sale  Search Gearslutz Go Advanced
Why is ableton switching my patches when playing back midi sequences
Old 12th September 2011
  #1
Gear Addict
 
J Gabriel's Avatar
 

Why is ableton switching my patches when playing back midi sequences

Is this a basic thing cause it started happening to me lately and i dont know why ..... so im at my buddies studio and recording midi through his little phatty which is then sent back to the phatty for recording audio. im playing the bass notes and i'm programming the sound to fit the feel of it. when it loops back it changes the patch or an aspect of the patch and its super annoying. this also happened to me recently using some software synths, it would keep switching it back to the same random patch for no reason... is this a straightforward problem, what am i missing here? thanks in advance
Old 12th September 2011
  #2
Lives for gear
 

It may be recording the patch changes as automation?
Old 12th September 2011
  #3
nms
Lives for gear
 
nms's Avatar
Sounds like you're playing back a midi file you got from somewhere else? Go into the midi clip and erase the program / bank designation boxes so you don't encounter a patch change.
Old 12th September 2011
  #4
Lives for gear
 
sleepwalker's Avatar
 

Quote:
Originally Posted by J Gabriel View Post
Is this a basic thing cause it started happening to me lately and i dont know why ..... so im at my buddies studio and recording midi through his little phatty which is then sent back to the phatty for recording audio. im playing the bass notes and i'm programming the sound to fit the feel of it. when it loops back it changes the patch or an aspect of the patch and its super annoying. this also happened to me recently using some software synths, it would keep switching it back to the same random patch for no reason... is this a straightforward problem, what am i missing here? thanks in advance
Your midi clips have program changes in them. There are several ways to fix this problem. My voyager has a mode to ignore program changes. Or in Live, you can double-click the clip and in the little clip inspector, turn the patch to "none" from e.g., 20 or whatever the patch was.

Not Live's fault though. it's simply doing what you're telling it to do.
Old 12th September 2011
  #5
Gear Addict
 
J Gabriel's Avatar
 

cool guys thanks for the tips!
Old 12th September 2011
  #6
Gear Addict
 
J Gabriel's Avatar
 

actually, the problem persists. It's a midi file i recorded myself, not from somewhere else. In "Bank", sub-bank etc it says "none" so i dont see where the midi program commands are taking place. Perhaps there's a way to set the phatty to ignore it as in the voyager but i just started using this setup , guess it'll take some more pokin around !
Old 13th September 2011
  #7
Gear Maniac
 
soundmagus's Avatar
 

In Cubase you would open the midi file in the list editor and remove the program change that way, does Ableton have something similar?
Old 1st July 2015
  #8
Here for the gear
 

I have cubase 5.1 cracked , i'm having same problem , reinstalled program good few times never had an issue like this in years of using this version !
Old 1st July 2015
  #9
Here for the gear
 

If anyone can help then please let me know, Thanks >
Old 1st July 2015
  #10
Here for the gear
 

you're sending a program change by midi?

through MIDI CC 0 probably
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump