The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Synths for sale  Search Gearslutz Go Advanced
XL-7 tempo change in song mode
Old 13th January 2018
Gear Head

Thread Starter
XL-7 tempo change in song mode

Anyone still using the E-Mu XL-7 (or other Command Stations) out there? I've had mine for several years now but I still find it rewarding to go back to.

Normally I don't use song mode on this machine, preferring to use pattern mode, and muting/unmuting the tracks manually. The other day I decided to use song mode though, and I wanted a bit of a ritardando at the end. I was expecting there to be some way of entering tempo changes into the song, but I can't find out how, and the manual is conspicuously absent on the subject too, yet clearly describing how to enter tempo changes into patterns.

I've tried changing the tempo while doing realtime write, but although I can enter notes, MIDI events and track mutes/unmutes in this mode, tempo changes do not get recorded.

In song mode on this machine, there are two tracks, one labeled 01 and one labeled CT. Patterns have a CT - Conductor Track - too, and that's where tempo changes are entered, but try as I might I can't figure out how to enter them into a song. The conductor track is always empty. An odd thing is that it's still possible to specity which sources tempo changes are taken from - patterns, the song, or both, which is strange if there's actually no way to enter them.

Has anyone else managed to accomplish tempo changes in songs on this machine, or is it a feature that was planned but never fully implemented?
Old 13th January 2018
Gear Maniac
7up's Avatar

its interesting that EMU could have just improved on the ASR X but instead made a rompler with the same pad layout.
Old 13th January 2018
Here for the gear
I hadn't tried the CS song mode before either, but as I'd been experimenting with tempo changes in pattern mode a while ago, I decided to give it to a try!

I didn't have a clear picture how I'd managed to enter the tempo change events last time - I just remembered that I'd had to fiddle about for quite a while before I succeeded in doing so - so I decided to re-learn the procedure in pattern mode first. And at first I wasn't able to make it work at all! The repeat key didn't seem to work for entering the events, nor did the enter key or the pads. I tried all possible recording modes too. Nothing.

After trying all sorts of things and still failing to get any tempo change events to stick on the conductor track I decided to start a new pattern. This time the procedure for entering tempo change events worked exactly as described in the manual! I then decided to erase all tempo change events. I had a one bar long pattern, but tapping the erase button somehow went through 32 bars before the conductor track was "empty"! And after that, I was again back in the state where I wasn't able to enter any tempo change events! Seems very much like a bug to me! (I'm on OS 2.0.) I even got the machine to completely freeze (being forced to reboot) TWICE while examining the weird behaviour!

In the end I managed to manually enter tempo change events on the conductor track in song mode as well. At first I wasn't able to make that work either, but after some mucking about, I got it to work. For some reason the erase button seems toxic in conductor track event edit mode on my machine at least. (I suspect there might also be some other conditions that trigger that erratic behaviour. Perhaps something like if some other changes have been made to the pattern, but it's still unsaved and in the temp edit buffer... Should investigate further.)

Whether recording tempo changes in real-time is possible or not, I do not know. I haven't done any research on that subject yet...
Old 14th January 2018
Gear Head

Thread Starter
Yeah, song mode seems buggy, I've had track mute/unmute events turn up that I didn't enter, and at one time playback of mute/unmute events didn't work according to what was actually in the track. I'll fiddle a bit more with it and see if there's some method to the madness. Thanks for the idea of testing on an empty track.
Old 14th January 2018
Gear Head

Thread Starter
Ok, pilot error. The manual says "Move the cursor to the lower line of the display and select tempo", and I stupidly assumed that since the second line of the display read "-no events in track-" that I couldn't change it. However, that's exactly how it's done, both in song and pattern mode, change the "-no events in track-" to "tempo: 120 bpm" using the scroll wheel as usual, and then adjust the actual tempo and the exact event location. Duh.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump