The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Audio Technica LP120 USB 'No Sound' Turntables
Old 26th June 2017
  #1
Here for the gear
 

Audio Technica LP120 USB 'No Sound'

Okay, hopefully this is in the right place.

But I bought an Audio Technical LP120 Recently and UPS did a number on it.

I managed to get everything cosmetic fixed and it turns on and runs fine.

The issue is though is that it provides no sound, not even thru the USB

Not only that the tone-arm doesn't reach the end of the records I tried to play, unless I turn the thing that holds it in place.

Is there a way I can fix this?

This is my first turntable and the only thing I haven't done is change the cartridge or open it up to check the inside yet, because I wanted to see if I could fix it other ways first before popping the sucker open.

And I can't find a solution anywhere!
Old 6th July 2017
  #2
Here for the gear
 

No sound even through USB? Very weird! I wonder if your needle is actually tracking your record? Is the needle still attached to your tonearm? Should be a green stylus assembly if its a new one. When you play a record do you hear surface noise(quiet music coming off the surface of the record itself)? What do you have your tracking force set to?
Old 23rd March 2018
  #3
Here for the gear
 

well after much fiddling around, I finally got the USB part to function (hurray!!!)

Unfortunately I still haven't gotten the Audio ports to work correctly, I even bought a separate pre-amp to see if that would work, I have tried multiple speakers, I have tried multiple headphones, I even tried swapping cables around and putting them in backwards, hell I even tried different cables (I have a million of them and they work so thats not the issue), I even tried switching the phono and line switch and turning it on and off each time I switched anything to see if that was the issue...

Bonus, I'm getting 'A' noise when hitting the audio cables on the preamps metal parts, but I'm not sure if that's from the preamp itself or the record player, point is, record player works with usb but not thru the cables.... should I just finally pop this sucker open and find out whats wrong? or just give up and stick to usb/pc?
Top Mentioned Products
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump