The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Routing channels for MIDI controling my keyboard?
Old 5th December 2018
  #1
Here for the gear
 

Routing channels for MIDI controling my keyboard?

Hi,

I've already asked about this in my other post here link: Using MIDI to trigger keyboard sounds )

Long story short, I am trying to set up and connect my Roland Juno DS into my computer in such a way that I can create a MIDI sequence in Reaper and let it be played with the sounds of Juno.

I was told a USB cable connecting the keyboard into my computer and then setting the output of the MIDI into the input of the keyboard should be enough. While I understand all of this and I believe it to be basic stuff, I am completely lost in trying to set up routing for this stuff

I've been trying to do this for months now, googling didn't help and I've got no one else to ask for an advice so that's why I ended up here.

If there's anyone willing to help out a lost soul in Reaper and maybe provide some kind of how-to or assistance (for a dumb*ss like me), I'd be very thankful.
Old 10th December 2018
  #2
1. Look in Reaper Prefences - midi devices to make sure your keyboard shows up there. If not, look for the USB driver for your keyboard at Roland.com and install it.

2. Once the device shows up in Step 1 (indicating Reaper can find it), set it to Enable (*not* control).
While you are at it, Enable the Juno entry in Midi Output section also.

3. Arm a track for recording, then right-click the level meter, select Midi input - Juno - All Channels

4. Click record on the Transport. You should see a midi item in the track being recorded.

All the above is for getting Midi INTO Reaper.

5. To feed Midi from Reaper, back to the Juno, click on the Routing panel on your Midi track, and select (on the top right of the routing window) Midi hardware output. Select Juno - All channels.

Use the transport to play back the Midi you recorded. Sound should be generated by the keyboard when this happens.

Note: If you want to record the audio out of the keyboard into Reaper, that's another thing. The Juno has capability to do simple stereo audio through the USB also, but I don't know much about it.

Another note: The Juno DS has 2 USB ports. One is strictly for a thumb drive - Make sure you are using the correct port.

A last note: Spend a little quality time with the Juno owners manual. Roland manuals aren't great, but it's the best place to start. Reaper also has a manual.

I highly recommend you watch the Midi videos on this page once you get things going:
REAPER | Videos
Old 5th June 2019
  #3
Here for the gear
 

Necro bump.

I've been trying to do this exact same thing but on my Roland Fantom G7, glad to know I'm not the only one who couldn't figure this out. I was able to accomplish the steps that Philbo King laid out in his post (thank you!) but whenever I play my midi sequence my Fantom goes ape****. It'll randomly change patches, it'll play the sequence way faster than I've dialed in and it'll play random notes with infinite sustain. I have no idea what the deal is. I'm using standard midi cables into an RME Babyface Pro. I'm running Windows 10. The Fantom G-series doesn't have drivers for Windows 10 which is why I've been running standard midi.

I can plug the sequences into into VST Synths but I've got some patches on my Fantom that I'm very fond of. I'm hoping there's a way around this that doesn't involve me buying a bunch of new **** when I've already got this really fierce workstation on my desk.
Old 6th June 2019
  #4
Gear Guru
 
Muser's Avatar
some ideas might be

if it plays a sequence twice as fast, it might be getting a clock signal which is being interpreted as twice as fast. so the phantom might be receiving a feedback loop because it’s set to also generate a clock from its output. putting the phantom into external midi sync may stop it generating a midi clock etc. then you might want to set phantoms midi device in reapers preferences, to start its midi clock a little later. you can set that up in Reapers Midi device by double clicking on the output device lane for the destination device which feeds the phantom. it may be set to generate clock. if it's not set to generate clock, it's some other weird behavior happening. if it IS set to generate clock, set it to Not send an SSP. setting a negative clock start offset for the device doesn't seem to work ime. so hopefully you only need a positive delay.

in that respect, it might also be a good idea to set all your audio drivers preferences across your whole system, to one single sample rate and one single bit depth. this also applies to any other audio applications preferences. because what can happen is, when you load another audio application which is set to a different sample rate, that can sometimes be forcing the driver to switch back and forth the sample rate, as you switch between those loaded applications. that switching provides and opportunity for some bugs to emerge, so it’s better to have all that as it should be. Reapers clock delay offset is impacted by changes in the sample size in Reapers sample buffer settings. which means by extension that, a different sample rate may well also impact this, because the time divisions of one sample are different at different sample rates. e.g. one sample at 44K is not the same time division as a sample at 48K.

as for Repaers Track settings, if you right click to the left of the little arrow where you select the input source or, left click to the right of the active monitor arrow, you should see a list with this option as part of the list. Record: Input (Force Record) it might be that if you set that forced to audio only, that it blocks a midi thru.

another method might be to try using ReaControlMidi plugin on the track and click on the top right midi radio button, you can see that on midi output, you can set it to (Midi output disabled) that might be another way of stopping midi being echoed back to the phantom. or you might be able to disable its own local midi control. that way the midi on the phantom won’t trigger the phantoms engine, but as the midi echos through reaper, it will respond from the midi in. as opposed to locally + midi in.

in those kinds of situations I tend to prefer using a keyboards local control set to on and figuring out how to block any DAW midi thru echos. this is assuming this is where the problem is coming from. also hit the reset midi drivers radio button in reapers preferences, so you know Reaper has refreshed to for any changes.

if you get a track setup which start to work the way you want, save that track as a template and always load the template for the job.

Edit: I actually just tried these above options for blocking already recorded midi, and that didn't seem to prevent any midi getting out. but your condition is potentially related to live midi (getting back thru) which I haven't yet tested for. take into account, my testing time on this was minor. so I may have missed something simple I could catch otherwise.

the only way I found to stop midi getting out from the track, is by just disabling the Midi output in the Track Routing window.
so then the midi will play a plugin instrument and do so while not sending the midi out over USB.

Last edited by Muser; 7th June 2019 at 05:02 AM..
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump