The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
X-Touch and Sonar/CbB
Old 24th April 2018
Lives for gear
fireberd's Avatar
X-Touch and Sonar/CbB

I posted this on the Sonar forum but no responses.

I had a previous post about this problem and thought it was resolved, but its not.
If I power on my equipment rack, which includes the X-Touch (and its shown as working OK in the Device Manager) and then start Sonar Plat or the newer CbB, the X-Touch is shown, correctly, as a control surface BUT apparently Sonar is not communicating with the X-Touch as the motorized faders are not working and the track indicators/switches do not work. This appears to be a Sonar/CbB problem as I can start Studio One 3 or Cubase LE and the X-Touch is working OK with them.

I can get Sonar/CbB to communicate with the X-Touch by deleting the X-Touch and adding a new control surface, Mackie Control. After the delete/add the X-Touch works in Sonar/CbB.

I have the latest Windows 10 Pro, Version 1709 Build 16299.371 and a dual boot Windows Insider V 1803. It acts the same on both.
Old 24th April 2018
Gear Addict
Zargg's Avatar
Hi, Jack. Did you try to PM Azlowe/Alexey regarding this? That would be my 1st choice.
I'm using a FW1884 as my CS, and it works both in Mackie and Native mode. Never had an issue with it not being recognized by SONAR/CbB, Studio One or MiXbus.
All the best.
Old 24th April 2018
Lives for gear
fireberd's Avatar
I was hoping Azslow would have responded, but I haven't seen him post on the Sonar forum for a while.

I suspect a Windows 10 update caused the Sonar problem. Something that has been heavily discussed on the Sonar forum, a Windows update "breaking" Sonar. It worked OK for a long time but I've had problems the last couple of months (that I know of). The CbB version is basically the last version of Platinum and just the rebranding to "Cakewalk by BandLab" and the reason it has the same error problem.
Old 28th April 2018
Lives for gear
fireberd's Avatar
According to Azslow, on the Cakewalk Sonar forum, its a known (at least to him) bug on how Cakewalk handles MIDI devices. And the reason Studio One 3 and Cubase do not have the problem (at least on my Win 10 PC).

One possible bright spot. Along with my production Win 10 Pro I have a dual boot with the Windows Insider advanced/beta versions and the current Insider version is the 1803 "Spring" Creator's upgrade. This was supposed to be released to the public earlier this month but has been delayed and now scheduled for release Monday, April 30. I have Sonar and CbB installed on the Insider version and the X-Touch is working OK in that installation. I notice a different version/date for the Microsoft driver for the X-Touch and there is a chance that will fix the problem. The X-Touch/Sonar worked OK for two years or so (from new until last approx. 6 months) so that makes me think a Windows update (possibly the Fall Creator's Upgrade) with that new Driver may have caused the Sonar/CbB problem. Windows "breaking" Sonar has been a hot topic on the Cakewalk forum.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump