The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Faderport Madness with PT10 DAW Software
Old 3rd May 2013
  #1
Gear Addict
 
soulfield's Avatar
 

Faderport Madness with PT10

Having searched GS and every other forum I'm at a loss with the Faderport and PT10.2.0

Have gone through all the recommended firmware, and installer versions, and combinations of one driver and another firmware as recommended in several different threads.

Made sure faderprot was first HUI controller

Made sure USB cable is good and not plugged into a USB3 port as a thread mentioned that was a potential problem.

made sure the power supply works and is properly plugged in.

In the end the transport section works great.

Banking + channel selection works for the most part

Fader control buttons - read, write, touch all change the status of the selected channel in PT and the touch function will engage write when you touch the fader itself.

The problem is fader movements do not seem to control or transmit anything to the track in PT. In other words if I put the channel in "touch" soon as I touch the fader it engages and begins writing automation, but its a flat line, moving the fader up and down does nothing, and PT just writes a flat level of automation.

Also no read from PT to the fader on the faderport. The dam thing just wont move and its brand new???

Writing automation is the main reason I want this thing, the transport is just a plus. I know PT is moving away from any HUI support but thisthins is advertised to have a limited ability with PT. The fader should work.

has anyone managed to get this fader to function???

help, Ive fallen and I can't get up!
Old 3rd May 2013
  #2
Lives for gear
 

I remember when I bought my faderport I hooked it up and immediately upgraded the software, and that made it (particularly the fader) not work.

I - think - the version of the faderport firmware you need is 1.3.3, as opposed to version 1.3.5, which was the one causing issues.

Do a search about the issue and I think you can find some reading about it.

If it turns out you need 1.3.3 and can't find it online PM me and I'll email it to you. I just looked and I have 1.3.3 and 1.3.5 if you can't find them.

Old 3rd May 2013
  #3
MFW
Gear Maniac
 

I have the faderport working great (including the motorized fader) in PT 10.3.4 on a Mac (so this may only apply to a Mac if you're on a pc). Basically, I followed the same steps I troubleshot on the apple forums to get it working w logic 9 64 bit (which it does as well).

The key is to install the OLDER firmware with the NEW drivers.

Goto presonus' site and download the Faderport 1.2 installer. Click okay when it says you have a later driver / firmware. Install the driver, then install the firmware associated with 1.2.

Now, download the v1.35 installer from presonus. Install the driver but do NOT update the firmware. Once you've installed the new driver just quit the program. Now you should have v1.35 driver w the v1.2 firmware.

Next, goto pro tools and set it up as an HUI, making sure it's on top of
The list (mine wouldn't work unless its at the top). Now you might need to power cycle the faderport or restart pro tools, but this SHOULD work.

Following these steps (as well as one additional step w adding a bundle file
For logic 64 bit), I have my faderport working perfectly fine, motorized fader and all, in PT 10 and Logic 9 64 bit, on OSX 10.8.3.

Hope this works for you! And props to this thread on apple support, in which we worked out this combo of driver / firmware to wake up the faderport.

https://discussions.apple.com/thread...art=0&tstart=0
Old 3rd May 2013
  #4
Gear Addict
 
soulfield's Avatar
 

Thanks

Thanks guys!

I will be trying both of these solutions in a few hours when I hit the studio.

Im on a WIN7/64 machine I built, but hopefully one of these solutions will work.

Finally got a "tech" from presonus on the phone and he said the 1.38 "motorized fader solution" will work, but so far no dice.

Will update this afternoon.
Old 3rd May 2013
  #5
MFW
Gear Maniac
 

Quote:
Originally Posted by soulfield View Post
Thanks guys!

I will be trying both of these solutions in a few hours when I hit the studio.

Im on a WIN7/64 machine I built, but hopefully one of these solutions will work.

Finally got a "tech" from presonus on the phone and he said the 1.38 "motorized fader solution" will work, but so far no dice.

Will update this afternoon.
Awesome good luck! Hopefully you can get it working and out of paper weight status like I did. When functioning, this is a fun / useful unit for transport and writing automation. Who doesn't love motorized faders?
Old 4th May 2013
  #6
Gear Addict
 
soulfield's Avatar
 

Still a paper weight

Thanks guys for the suggestions!

No luck with any of the new approaches.

Tried new combinations with 1.2, 1.3.3, 1.3.5, 1.3.8 the last of which is refered to as a "motorized fader solution" on the presonus website and was recommended over the phone to me by a Presonus Tech yesterday.

I don't know what else to do.

Really want to have this thing functioning but the transport is all I can get to function.

Another detail is while the fader buttons write | read | touch do change the status of automation in PT the buttons do not light up on the fader port, and while going into write or touch the fader does not provide any data to the automation track in PT. Just a flat line.

Its gotten to the point where I have uninstalled and reinstalled at least 35 times.

Finally I just started pushing buttons stop | undo at the same time which appears to put the faderport into different modes. I assume this is for operating with different DAWs. While hitting subsequent buttons once in this mode I managed to get the Write | Read | Touch buttons to light up and at one point the fader moved to the bottom on its own, so I know the motor on the fader works, and the buttons for fader mode function!

This thing just does not want to paly with PT 10.

Can anyone confirm a version of PT10.x.x that works with the faderport version 1.x on a Windows7/64 OS???

So frustrated, and really want this thing to function but right now its just a transport with a dummy fader hanging of of it.

Any help greatly appreciated

Can anyone confirm a version of PT10.x.x that works with the faderport version 1.x on a Windows7/64 OS???
Old 5th May 2013
  #7
Gear Addict
 
soulfield's Avatar
 

Tried PT10.3.4 with no luck

I'm out of ideas guys!

So I tried the PT 10.3.4 update along with all the previously discussed combinations of faderport drivers and firmware.

No change in function of the fader, but now with any use of the faderport I get the message "Unable to communicate with HUI. Please power cycle HUI device" This is even though the transport and channel select still work. but no fader data

This will come up every 30 seconds or so. Obviously I tried power cycling, removing and resetting the device in PT peripherals and cycling PT and Windows.

But after pressing play or switching channels a few time the message always returns.

Im at a loss here. Just cannot think of anything else to try.

The prior advice of the Presonuss tech to use 1.3.8 didnt help so I have submitted a "ticket" in writing to Presonus Tech support. If they can't get this squared away than I guess its time to sell this piece.

I was really excited about this controller and it a shame there is no solution for this.

I hate blanket statments about compatibility but having gone through all this I will have to say from my experience that THE FADERPORT AND PT10 ON WIN7 DOES NOT WORK.

Presonus does not seem to concerned about it so I guess we will see if they even respond to my second support inquiry and offer a solution.

I guess I'll ask again, Any thoughts or something I couild have missed?
Old 5th May 2013
  #8
Gear Head
 
verme's Avatar
 

I like FaderPort (wish others made similar simple controllers with just the buttons you need), used it with Samplitude & Cubase and thought about getting one for PT 10 but after reading Presonus comments on their web site decided not to. Avid seems to want to support only their proprietary format (and controllers):

Quote:
FaderPort's Pro Tools controls are limited by how Pro Tools interprets HUI commands.

The problem is that Pro Tools no longer supports HUI protocol in it's newer versions of is software. Starting with Version 9 and now with 10 we are seeing a continued degradation of HUI functionality with each incremental dot release of Pro Tools. Avid has already informed us that they do not intend to address any issues with HUI as they have moved on to EuCon which is a proprietary format for their own line of controllers.

PreSonus is investigating which functions that used to work under HUI in previous versions of Pro Tools can be corrected for use with newer versions of Pro Tools.
Link: Pro-Tools + Faderport : HUI no longer supported by Pro-Tools : PreSonus Audio Electronics
Old 6th May 2013
  #9
Gear Addict
 
soulfield's Avatar
 

What gets me is that the "PT HUI Functionality Grid" that they post clearly shows that while certain features do not function in PT10.x on PC, the Fader clearly does, along with the features important to me. Basically transport, and fader writing data to PT is all I need.

Still no response form presonus and I'm afraid that this is a dead end with no support of solution from presonus.

I'm going to give it a few more days to see if they respond at all, and will research further to try and come up with a solution on my own.

For the time being im still up **** creek without a paddle...........
Old 11th May 2013
  #10
Lives for gear
 
Travst's Avatar
Ah, the FaderPort. I bought one used and it was quite a while before I could get it working properly. That was back when the 1.2 driver was the ticket. I am now using the 1.3.8 driver, but it didn't work the first time. The trick for me was to keep updating the firmware until the fader works. I had to do the same thing with the 1.2 driver. Weird, but it worked for me. I believe that I loaded it five times before 1.3.8 worked. With 1.2, it was probably 8 times.

I should add that I'm a Reaper user. I happened on this thread because it came up in a search.
Old 15th May 2013
  #11
Gear Head
 
BajenKeno's Avatar
 

Question to get some clarification: The faderport will work as it should with PT10 on mountain lion, but not on win7?
Old 15th May 2013
  #12
Lives for gear
 
Travst's Avatar
I am using it with 64-bit Win7. Does it show up in the Devices and Printers screen? If the driver installed properly, you should see it there. If not, that is the first thing to work on. As I recall, I had some problems with getting it to show up there when I first started with it.
Old 5th April 2015
  #13
Here for the gear
 

Try resetting the faderport with the little pinhole on the back and then re-upgrade to the latest firmware. Worked for me with PT 10.2. and Win7.
Now everything works except output select, which is not supported.
Old 27th August 2015
  #14
I can confirm that 1.3.3 firmware with 1.3.5 driver has the fader working perfect where 1.3.5 driver with 1.3.8 firmware didn't. Mac 10.8.5, Reaper, Pro Tools, Logic
Old 4th October 2015
  #15
Gear Addict
Bit of a 'necrothread' but I just bought a FaderPort - followed install instructions - and the fader won't move...

It did a firmware update as part of the 1.3.5 installer package...

To be clear.... Is installing this: FaderPort - 1.3.8 firmware - Motorized Fader Solution : PreSonus Audio Electronics the correct fix?

I'm Windows 7 running Studio One and Cubase 5
Old 22nd March 2016
  #16
Gear Maniac
 
Samuelito's Avatar
Just resurrecting this thread.
I was having problems with a new FP. Installed 1.3.8 firmware update with 1.3.5 driver (mac - pro tools 12)
I was not able to switch to the first 8 faders and I found out that the FP needs to be first in the MIDI controllers list to work properly.
Don't know why but now it works.
Hope this can help someone in the future!!
Cheers,

M
Old 27th May 2017
  #17
Here for the gear
 
Andre Fernandes's Avatar
I can't get it to work with WIN 10 Pro + Sonar Platinum and even PreSonus don't seem to know how to help me. Perhaps, if someone can give me some help, that'd be fantastic, here's my situation:

MY PC:
Windows 10 Pro | 64 bits | intel core i7-7700 CPU @ 3.60GHz | 16GB

1) I connected it my PC (regular USB with a MIDI keyboard also plugged) and it ran an automatic "install" so I was hoping it'd be plug and play. When I tried to connect it to Sonar, FADERPORT didn't appear in the Control Surfaces;

2) I read the manual but there was no CD so I created an account on their website and downloaded the firmware update. When I ran it I got an error message: "Error: Could not find FaderPort control surface. Check the cables to ensure it is properly connected and press Next to try again";

3) I tried again, this time I disconnected all other MIDI devices and tried it on USB 2.0 and regular. Same error;

4) After this, I tried an older installer I found here:
Why am I having trouble getting the faderport to work in my DAW? - Questions & Answers | PreSonus
It would run an installer (but not inserting the dll files) and then open again the recent firmware update that gives the error message;

5) As I couldn't get the installation done directly through plug or using the firmware and installer, I tried a manual .dll install:
Faderport.dll registration for Cakewalk Sonar – Knowledge Base | PreSonus

I copied the file to the right directory [C:\Program Files\Cakewalk\Shared Surfaces] but when I run the regsvr32 or C:\windows\SysWow64\regsvr32 register for FaderPort.dll I get the following error: "The Module FaderPort.dll failed to load. ...."

So, I don't know what else to try and I feel deceived.
Old 28th May 2017
  #18
Here for the gear
 
Andre Fernandes's Avatar
I was able to install it in WIN 10/ Sonar Platinum, after a lot of struggle.

1) If you get an error when trying to manually register the DLL, just download this microsoft MS Runtime:
https://www.microsoft.com/en-us/down....aspx?id=21254

2) After registering it, check if your device name (in your DAW) is "FaderPort Update Mode". If so, it happens that when the firmware update results in the error, that turns the device into that Null entity, that doesn't work. You just have to uninstall FaderPort and remove all entities from the Device Manager ( in "Audio,Video,Game controllers"). Them restart Windows and it will re-install it "virgin", to work.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump