The No.1 Website for Pro Audio
[FIXED] HDX NOT COMPATIBLE WITH 2019 Mac PRO!
Old 2nd January 2020
  #1
Here for the gear
 

[FIXED] HDX NOT COMPATIBLE WITH 2019 Mac PRO!

(NOTE THIS ISSUE HAS BEEN RESOLVED-although Avid has not released an official statement about their support of the 2019 Mac Pro, since their statement of it not being supported, I can confirm it is working for me. The included 6pin ancillary power chord from avid does fit into PCIe power outlet for slots 5&6 @75w (more on this below). I have it installed in slot 5 ((even though it’s a 16x)) and have slots 6&7 fitted with my two UAD Octo cards. After instal I had to update the firmware of the HDX card and then reboot. I also hit a snag with my Pro Tools Ultimate Upgrade, however, the awesome tech team over at Sweetwater was able to get Avid to get me a 30 day rental license on my iLok until Avid resolved their “My Avid Account“ issue. They have since issued me the right license and all is well!!! Thank you to all the posters who tried to help. The included Avid 6pin ancillary power cable does not easily fit into the new Mac Pro outlet, unlike the way it effortlessly plugged into my 2012 cheese grater, I was about to break the dam outlet off the motherboard trying to get it in, and don’t bother to wait for a click, it’s never coming. To get it out use a small flathead, and make sure as you muscle it out not to pierce the cooling system for the core right above it. My advise would be to go with Apple’s approved Belkin PCIe cable package until Avid updates these cables. I still have no idea where to put additional HDX cards, as the rest of the slots are 8 pin 300w connectors. Guess time will tell!!!)

Original Post:
So we just got our first new Mac Pro 2019 and a new Avid HDX card for it at the studio. After trying to communicate with Avid and Mac, and a ton of other vendors, it turns out this is the reality right now:

http://avid.force.com/pkb/articles/c...m-Requirements

We can't even believe this is the case, after spending a ton of resources on the new Mac Pro it's sitting in a corner as we have to use a 2012 Cheesegrater to keep working.

Is anyone getting the HDX to work in the new 2019 Mac Pro Tower?

PCIe 1&2, 3&4 are 16x lane with 8 pin connectors for 300w ancillary power supply.

Slots 5&6 are 6 pin ancillary power @75w. Slot 5 is 16x lane, slot 5 is 8x lane. Don't know about putting UAD Octo cards in the rest either.

We can't even get through to UAD and Avid is like trying to talk to the federal government. Customer service is sinking like a stone with these companies when it comes to getting a real tech on the phone. So bad. Please LMK if anyone has any luck, Thanks!

Last edited by PROVIDENCE MUSIC; 10th January 2020 at 08:13 PM.. Reason: Resolved
Old 3rd January 2020
  #2
Gear Guru
 
jwh1192's Avatar
Quote:
Originally Posted by PROVIDENCE MUSIC View Post
So we just got our first new Mac Pro 2019 and a new Avid HDX card for it at the studio. After trying to communicate with Avid and Mac, and a ton of other vendors, it turns out this is the reality right now:

http://avid.force.com/pkb/articles/c...m-Requirements

We can't even believe this is the case, after spending a ton of resources on the new Mac Pro it's sitting in a corner as we have to use a 2012 Cheesegrater to keep working.

Is anyone getting the HDX to work in the new 2019 Mac Pro Tower?

PCIe 1&2, 3&4 are 16x lane with 8 pin connectors for 300w ancillary power supply.

Slots 5&6 are 6 pin ancillary power @75w. Slot 5 is 16x lane, slot 5 is 8x lane. Don't know about putting UAD Octo cards in the rest either.

We can't even get through to UAD and Avid is like trying to talk to the federal government. Customer service is sinking like a stone with these companies when it comes to getting a real tech on the phone. So bad. Please LMK if anyone has any luck, Thanks!

did you purchase from a Dealer ???? or piece meal it yourself ????
Old 3rd January 2020
  #3
Lives for gear
 
bambamboom's Avatar
Ridiculous. Avid is just a constant pain that you should kick to the curb.

I divorced Avid last year and it was a great decision.
Sold ALL of my avid gear including DCommand, HD IO interfaces etc and ditched them completely.

Went with UA Apollo X, the sound quality is as every bit as good as the HD IO, monitoring is great (though you appear to have an AWS which is a great monitoring option), and don't miss anything about what HDX (or HD Native) could do to be honest. If you already have an existing UA plugin investment, you can transition without much pain, and can track with UA plugins with no latency concerns - no problem, and rock solid stable in my experience.

Sell your UAD cards, your Avid interfaces, and return the HDX card and get as many Apollo 16X's as you need to cover both your IO and UAD DSP. No need for PCIe cards, and you'll likely end up with money back in your pocket. In fact Apollo16X is about the same price as the HDX card, so you're already off to a good start.

I also left ProTools completely (now using S1 and Logic), but as a commercial studio that's likely a non-starter for you.

In short, why put up with Avid's crap any longer? Pull the plug and rid yourself of their drama.
Old 3rd January 2020
  #4
Gear Nut
 

Oh my.

Well it looks like I won't be switching to Mac.
Old 3rd January 2020
  #5
Gear Addict
 
bzone's Avatar
 

Do a little research, it’s up and running with 3 cards. You need the new power cables.
Old 4th January 2020
  #6
Quote:
Originally Posted by PROVIDENCE MUSIC View Post
So we just got our first new Mac Pro 2019 and a new Avid HDX card for it at the studio. After trying to communicate with Avid and Mac, and a ton of other vendors, it turns out this is the reality right now:

http://avid.force.com/pkb/articles/c...m-Requirements

We can't even believe this is the case, after spending a ton of resources on the new Mac Pro it's sitting in a corner as we have to use a 2012 Cheesegrater to keep working.

Is anyone getting the HDX to work in the new 2019 Mac Pro Tower?

PCIe 1&2, 3&4 are 16x lane with 8 pin connectors for 300w ancillary power supply.

Slots 5&6 are 6 pin ancillary power @75w. Slot 5 is 16x lane, slot 5 is 8x lane. Don't know about putting UAD Octo cards in the rest either.

We can't even get through to UAD and Avid is like trying to talk to the federal government. Customer service is sinking like a stone with these companies when it comes to getting a real tech on the phone. So bad. Please LMK if anyone has any luck, Thanks!

That has been a reality of Avid/Digidesign for decades. The term 'unsupported' doesn't mean "won't work". It simply reflects the configurations Avid have tested. Blue interfaces with PT11 and beyond is unsupported. HDX with some recent versions of PT running on 5,1 Mac Pros is unsupported. Blue Sync HD interfaces instead of a the newer grey ones is unsupported. The Command 8 has been unsupported since PT10...

It all still works though, just fine. I would hazard a guess that the vast majority of PT users are running something that is officially 'unsupported' just fine! Perhaps reach out to Octatonic and Co to see if they have any input. They have been reliable, levelheaded contributors over at the DUC for more than a decade.

Just to check, have you installed the 2019.12 HD Driver? and have you tried running Digitest to see what it shows? A PRAM reset after installing the HD Driver can help if HDX isn't appearing, but I would definitely try the Belkin aux power kit that is being recommended by HDX users running a nMP.
Old 4th January 2020
  #7
Here for the gear
 

Thanks to everyone trying to help. Got it working with the awesome support of my tech support friends over at Sweetwater! Sweetwater backchanneled with Avid deeper than I could, then did a brilliant screen share and got it all working!
Old 4th January 2020
  #8
Gear Guru
 
jwh1192's Avatar
Quote:
Originally Posted by PROVIDENCE MUSIC View Post
Thanks to everyone trying to help. Got it working with the awesome support of my tech support friends over at Sweetwater! Sweetwater backchanneled with Avid deeper than I could, then did a brilliant screen share and got it all working!
would you care to share a little bit more info on the Fix ?? a Nutshell not Details !! someone else here might need it before long !!!

if not, no worries ...
Old 5th January 2020
  #9
Gear Addict
 
bzone's Avatar
 

All information is over at DUC. Cards go in x8 slots, Belkin makes the new power cord, load PT Ultimate for Catalina in. It functions. How well yet, more testing needs to be done; audio ok, plugins for Catalina ok. Once everybody upgrades their software for Catalina we will know more.
Old 7th January 2020
  #10
You need to change the subject on this thread. It’s not true and now all the trolls are coming out!
Old 10th January 2020
  #11
Here for the gear
 

Agreed! How do I do that??? I struggle with the interface here!
Old 10th January 2020
  #12
Quote:
Originally Posted by PROVIDENCE MUSIC View Post
Agreed! How do I do that??? I struggle with the interface here!
I think u go to your initial post and then EDIT
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump