The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Error While trying to Synchronize Audio and Midi Condenser Microphones
Old 13th September 2014
  #1
Gear interested
 

Error While trying to Synchronize Audio and Midi

Hello everyone. I have a late 2010 iMac i3 upgraded to Mountain Lion 10.9.4.

For the last two years I have been getting this error when Using Logic Pro 9, recently upgraded to Logic X:
"Error While trying to Synchronize Audio and Midi" When ever I get this message, I get a bunch of popping and clicking noises and my COMPUTER RUNS SLOW, even when I try to look at youtube or listen to iTunes. It tells me my sample rate is recognized at 40973 and to check conflict between Logic and external device. Don't know how to do that.

Some of the plugins I have are Trillian Bass, Kontakt 5, Focusrite mixers, Bass Station, Addictive Keys, etc. I also have a scarlett 2i2 audio interface, but it even does it when the interface isn't plugged in.

I know every little about audio DRIVERS, and the Coreaudio whatchamajigger. I even tried to get help from the so called apple "genies" but to know avail. Does anyone have a "Simple yet effective solution to what I can do about this. Even if its not so simple, please be as plain as possible. I love music but I'm no tech head. Thanks.
Attached Thumbnails
Error While trying to Synchronize Audio and Midi-screen-shot-2014-09-08-4.45.12-pm.jpg  
Old 14th September 2014
  #2
Gear interested
 

Wow! One-hundred-seventeen of you saw my post and not one spoke. Really? Wow. Please don't be stingy with your knowedge. Help a fellow musician out. I just had to quit my Logic Pro X again, twice since I've posted. This is really annoying, but what's infuriating is that some of you can help but choose not to. Not cool at all.
Old 14th September 2014
  #3
Lives for gear
 
oceantracks's Avatar
 

From APPLE:

The following error message may appear intermittently while playing:

"Error while trying to synchronize Audio and MIDI"
Resolution

The basic issue when this happens is that Logic is either not getting audio data at the sample rate it expects, or the sample rate is fluctuating. Depending on the specific cause, here are some tips for resolving this:

In most cases, Logic can set the sample rate for the audio interface, but sometimes this is not possible. Check the sample rate for your audio audio interface and make sure it matches Logic's setting. If the settings match, try changing Logic's sample rate to a different setting and then back again.
If you have any devices digitally connected to the audio interface, make sure that only one device is set to be the master clock.
If you have combined multiple audio interfaces by configuring an Aggregate Device in Audio/MIDI Setup, make sure that the devices are digitally connected, and that only one device is configured as master clock.
If you are using Word Clock to sync multiple devices, be sure that all Word Clock connections are properly terminated.
Choose Audio > Audio Hardware & Drivers and try increasing the I/O Buffer size.
Try freezing tracks that use plug-ins that put significant load on the processor.
If you are running other software or hardware that can send MTC or MIDI clock, but intend for Logic to be the sync master, turn off Auto Sync In for Logic, to prevent Logic from receiving sync externally. The Auto Sync In setting can be accessed by click-holding the sync button on Logic's Transport.
If you are syncing Logic to another application or device via MTC, make sure that both Logic and the sync master are set to the same format. Make sure that Logic is not receiving both MIDI Clock and MTC. Also, configure the Audio Sync setting to "External or Free" in case the system is resolved to external Word Clock.
If you using a Reactor ensemble that syncs its LFO to the song tempo, try bypassing or removing the plug-in.
If none of the above helps, try switching to Built-in Audio. If this resolves the problem, check for updated drivers for your audio and MIDI interfaces."


Also, people have reported success by increasing their buffer sizes, and also by making sure you have the most recent audio driver for your interface.

Also try a different project (new project) and see if it continues. Sometimes a project can get corrupted, though this is probably unlikely.

I have seen this several times over the years....but I usually ignore it and click somewhere else in the project and hit play again and it goes away.

Let us know how it works out!

Tom
Old 15th September 2014
  #4
Gear interested
 

Ok thanks Tom I will try it. Do I find the sample rate in the core audio on my Mac computer?
Old 15th September 2014
  #5
Gear Maniac
 

look at your CPU stats in the screenshot. Most of the time it's just the instrument plugin on the selected track killing 1 of your cpu cores.
increase the i/o buffer or create an audio track and select this while playing back.
Old 15th September 2014
  #6
Lives for gear
 

Try all of the above plus your internal sound card.
Old 19th September 2014
  #7
Gear interested
 

Ok So I have a modded black lion digi 002 and I'm getting a similar problem but the sample rate is different it says "Error while trying to synchronize Audio and MIDI. Sample Rate 41055 recognized.
Check conflict between Logic Pro X and external device." Im running logic Pro x and I have the core audio plugin from avid. The plugin recognizes the digi and so does logic. also idk why but the 1394 light turns off when using but it will turn on if I switch the clock source and optical format settings in the core audio plugin
Old 20th September 2014
  #8
Gear interested
 

Sorry I'm just getting back. Thanks Tom for your advice. I increased the buffer size as you suggested and not one time did I get popping and clicking noise. Thanks again for your advice. The only issues I have now are, that sometimes, I get an overload error causing my playback to stop. Also, a track will out of the blue, stop producing sound. I usually switch to another track and then back to original track, and that fixes the issue momentarily. Any advice?
Old 21st December 2015
  #9
This is an old thread but just thought I'd report, what worked for me was to just click somewhere else in the project. This is now Logic 10.2 running on Yosemite with an Apogee Symphony, guess this problem is here to stay!
Old 21st December 2015
  #10
Tui
Gear Guru
 
Tui's Avatar
In my experience, there is always a reason when this error message pops up. It's a good idea to try to find out what that reason is.
Old 14th July 2016
  #11
Gear Nut
 
joec's Avatar
 

Cautionary tale

I recently encountered this issue, and it puzzled me because I thought that I hadn't made any changes to my setup.

As it turns out, I had made a change. I have a rMBP that is connected to my audio rig, but instead of firing up everything, I just turned on the computer and made a few changes to a Logic Pro project. In order to listen to the changes I had made, I switched the Audio Device to Built-in Output, and forgot to reset it to back to my recording interface, and when I fired up my recording rig, and attempted to recored, I got the dreaded:

"Error While trying to Synchronize Audio and Midi"

message. It took me a couple of frustrating sessions to diagnose that my problem was self inflicted.

It is diversions like this that have led me to setup a dedicated audio workstation for recording that I don't touch in the first place, and I violated my own rule much to my sorrow...
Old 21st October 2016
  #12
Here for the gear
 

Error While trying to Synchronize Audio and Midi Reply to Thread

what worked for me is going to mac utilities folder in the applications area selecting Audio Midi Setup and changing clock source to mac on my audio interface
Old 25th November 2016
  #13
Here for the gear
Just worked out my stuff up. I realised I had previously changed the sample rate to 192 Khz in future anticipation I was planning on recording with that rate.

I booted up the interface at 44.1 Khz. Basically logic was right, I was wrong.

To find the sample rate, you go to FILE- PROJECT SETTINGS - AUDIO.

Make sure whatever is listed in Sample Rate matches what your AD/DA Converter is set to.
Old 19th December 2016
  #14
Here for the gear
 

So i've been using the exact same setup and software for 3 years, i've never had an issue until recently I purchased a couple new software synths and updated kontakt and reaktor, however the issue isn't with any of those, when I try to open SoundToys Decapitator (which doesn't use any of the programs I updated or installed recently) I get this error message: "Error while trying to sync Audio and midi, sample rate 40,105 recognized. check between logic pro and external device". well... there is no external device (other than my apogee duet which I've had for 3 years without this issue), I have no idea what i'm doing when it comes to this stuff, and the program literally worked perfectly days ago, and has for 3 years...clueless.
Old 31st August 2017
  #15
Here for the gear
Solved - Slow playing tracks

Quote:
Originally Posted by TheGhostOs View Post
So i've been using the exact same setup and software for 3 years, i've never had an issue until recently I purchased a couple new software synths and updated kontakt and reaktor, however the issue isn't with any of those, when I try to open SoundToys Decapitator (which doesn't use any of the programs I updated or installed recently) I get this error message: "Error while trying to sync Audio and midi, sample rate 40,105 recognized. check between logic pro and external device". well... there is no external device (other than my apogee duet which I've had for 3 years without this issue), I have no idea what i'm doing when it comes to this stuff, and the program literally worked perfectly days ago, and has for 3 years...clueless.
I'm just finishing off mastering a 35 song album and getting the slow-playing tracks. I've been doing all kinds of hours getting this mammoth album completed, bouncing my mixes down in 24bit / 96 kHz, then mastering them in Logic 9 also.
The dreaded ultra-slow playback, and the midi / audio sync error suddenly came up an hour ago, so after searching around for fixes I checked my Logic's audio settings to make sure they were on 96kHz, yes, then I tried changing it to something different and back again, nope, problem remained.

After several restarts of Logic and computer, I restarted my Mackie Onyx 1220, and that solved it. There must have been some glitch between the mixer and Logic.
Old 11th November 2017
  #16
Here for the gear
 

I encountered this audio/midi sync error message (along with some seriously glitchy playback) when I tried setting up my track with just one instance of Kontakt. Previously there were 4--which I know is theoretically supposed to impact performance but I had never seen much of a problem with it.

Anyhow, once the single instance of Kontakt was set up with its own set of instruments routed to aux channels in Logic, I mirrored all the plugins/FX I had on the original tracks and then deleted them. But AS SOON as I started to play the track back I started getting these errors/glitches/sample rate nonsense. I have no external interface hooked up; this is just Logic somehow no longer able to play a track that 10 minutes earlier it could.

The only thing that changed was setting up Kontakt to route out to aux channels. If anyone understands what this means and why it broke something, please clue me in.
Old 11th December 2017
  #17
Lives for gear
 
Macaroni's Avatar
 

I'm having this problem as well and seems to be linked to software instruments like EXS24 or Drum Kit, etc. If I freeze those tracks I don't get the message. But I can't freeze them until I finish tweaking things and the messages screw with that. Very frustrating. Nothing from Apple Support has solved the problem. I don't have anything in the project with the varying sample rates showing in the message, so I don't know where it's detecting that.
Old 12th December 2017
  #18
Lives for gear
 
Macaroni's Avatar
 

Update: I may have found a solution and discovered the cause. I was using Drum Kit with a bunch of plugins on that channel. Out of desperation, I put all the plugins on an Aux channel and routed the Drum Kit track to that Aux after removing all plugins. It occurred to me that some of the plugins might be upsampling and that might cause Logic to detect a different sample rate, resulting in the sync issues.

Whatever the cause, it works and I haven't had that dreaded message again.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump