The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Logic Pro X not receiving one specific MIDI note... help!
Old 19th October 2013
  #1
Gear Addict
 
Sequentialist's Avatar
 

Logic Pro X not receiving one specific MIDI note... help!

Hi guys,

I would love any help anyone at all can offer on this weird puzzle I'm experiencing with LPX.

I am a seasoned Logic user and am pretty comfortable diagnosing MIDI issues in general, but this problem absolutely has me stumped... and is really frustrating!

Here's a quick summary...

- When recording or playing MIDI (for example, a software synth let's say), every note played from my main MIDI keyboard - a Nord Stage 2 - is playing fine in Logic, with the exception of F2, which does not play a note. When I look at the "MIDI in/out display" in the transport screen area, I notice that the F2 in question is only sending a note-off signal for that one particular key, not a note-on signal.

Here are some of the things I have ruled out in trying to solve the issue:

- To ensure it's not a problem with the actual F2 key on the Nord, I have tried one of my other MIDI synths (a Kurzweil PC3, in fact). Logic has no problem receiving the note-on and note-off signal for F2 when transmitted from the Kurzweil.

- To try to narrow it down to Logic only, I opened Pro Tools, which was able to receive the F2 MIDI note from my Nord without any problem. This seems to clear the Nord of having any fault.

- In case it was some weird incompatibility issue with the instrument plug-in I was using, I tried another instrument plug-in. F2 still doesn't receive the note-on signal for that one note! (Which makes sense, as it seems to be a global Logic MIDI-in issue, not an issue with MIDI data once it is received by Logic.)

- I also decided to open MainStage to see how that would respond to the Nord playing the F2 note... absolutely fine!

- Back in Logic, I also tried changing the Nord's MIDI-out channel from 1 to 2... and strangely, Logic did receive the F2 note just fine in this scenario! (However, I need to use the Nord on MIDI channel 1, as there are other synths in the room that are assigned to different MIDI channels... so this is not really a solution to the problem.)

In a nutshell, it appears that Logic (yet not MainStage or Pro Tools) doesn't like receiving the note-on MIDI signal for that one note, F2, when it is transmitted specifically from my Nord Stage over MIDI channel 1!

I would love it if anyone could suggest anything else I should test or examine in attempting to resolve this problem!

Thanks in advance for any suggestions you might have!

Cheers,
Mike
Old 19th October 2013
  #2
Lives for gear
 

Are you sure the Kurz was transmitting on channel 1? Usually those "one note not working" in Logic is that this specific note has been assigned to control something or is set to a shortcut. Try resetting your control surfaces in Logic Pro menu in the menu bar. good luck.

KA
Old 1st November 2013
  #3
Gear Addict
 
Sequentialist's Avatar
 

Hey KorgAddict,

I am incredibly rude and forgot to reply to your suggestion... I looked into this further and you were spot on, that note was mapped to a control function. All sorted now - thanks heaps!

Cheers,
Mike
Old 5th February 2016
  #4
Here for the gear
 

Korg Addict!!! Thank The Lord Jesus for you! That fixed it! I found the controller setting that the note was assigned to and deleted it. Works perfect now.
Old 7th August 2016
  #5
Here for the gear
 

Quote:
Originally Posted by KorgAddict View Post
Are you sure the Kurz was transmitting on channel 1? Usually those "one note not working" in Logic is that this specific note has been assigned to control something or is set to a shortcut. Try resetting your control surfaces in Logic Pro menu in the menu bar. good luck.

KA
Maaaannn!!!! I know this is an old post, but i just created an account and logged in just to say THHHAAAANK YYYOOUUUUU MAAAAANNNNN!!!!!!!!!!!!!!!!!
Old 18th December 2018
  #6
Here for the gear
 

another happy reader

Thanks, you made my day.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump