The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Is this normal CPU behavior? (CPU Spikes)
Old 20th August 2019
  #1
Gear Maniac
 

Is this normal CPU behavior? (CPU Spikes)

Hi all,
I just got a whole new setup after my 2009 iMac died. I bought a 2018 Mini (6 core/i7/8gb RAM) and an Apogee Element 24, and purchased Logic X and am on the most current version.

I started a new project and created 1 instrument track, and added Logic's E-Piano, and 2 Soundtoys plugins, Decapitator and Little Plate. With the I/O buffer set to 32, 62 or 128, I get a core spike (maxed out) and audio crackles while playing. Setting the buffer to 256 fixes it, but then there's a bit of latency.

Is this normal? I thought my machine would be able to easily handle this. Are there any settings I can set so I can play/record with a couple of active plugins while using a small buffer size?
Old 20th August 2019
  #2
Lives for gear
 
mikeka's Avatar
 

Ah, the dreaded single-core LPX overload conundrum. Yes there are workarounds.

I created a project like yours on my i7 3.2ghz 2018 Mini and am getting the same results with a low (32) buffer.

Firstly, I've found a 128 buffer (sometimes 64) to be plenty tight enough to record. I am a keyboardist and have tracked other instrumentalists at 128 without latency complaint by the players.

Secondly, after you've recorded your part, create an empty audio track. Make that the active track for low-cpu, glitch-free playback. You'll notice that your cpu will go from near 100% to maybe 5-10% in this (32 buffer) scenario.

I'm assuming that in LPX audio preferences, you have multithreading set to "playback and live tracks".

Also, 8gb ram is a bit on the light side. I don't think that has much to do with your problem but you may want to expand to at least 16 at some point. I have 32gb ram in mine as I do use lots of VIs.

Hope this helps!
Old 20th August 2019
  #3
Gear Maniac
 

Quote:
Originally Posted by mikeka View Post
Ah, the dreaded single-core LPX overload conundrum. Yes there are workarounds.

I created a project like yours on my i7 3.2ghz 2018 Mini and am getting the same results with a low (32) buffer.

Firstly, I've found a 128 buffer (sometimes 64) to be plenty tight enough to record. I am a keyboardist and have tracked other instrumentalists at 128 without latency complaint by the players.

Secondly, after you've recorded your part, create an empty audio track. Make that the active track for low-cpu, glitch-free playback. You'll notice that your cpu will go from near 100% to maybe 5-10% in this (32 buffer) scenario.

I'm assuming that in LPX audio preferences, you have multithreading set to "playback and live tracks".

Also, 8gb ram is a bit on the light side. I don't think that has much to do with your problem but you may want to expand to at least 16 at some point. I have 32gb ram in mine as I do use lots of VIs.

Hope this helps!
Thanks for chiming in! Yep, I've got multithreading set to "playback and live tracks," and I just read about the trick of creating the empty audio track to select when playing back. I can live with this behavior, but I thought that the core wouldn't be overloaded with one instrument and 2 plugins.

Do you also have constant issues with bluetooth devices? My Magic Mouse 1 and Apple keyboard constantly disconnect or become super laggy, with the mouse being the worse offender. I bought the Mini knowing about these potential issues upfront, but it's really quite annoying now that I'm living with it. Wondering if I should buy a wireless mouse instead; the ones that use the USB attachment/dongle.
Old 20th August 2019
  #4
Lives for gear
 
mikeka's Avatar
 

Quote:
Originally Posted by tfunster View Post
I thought that the core wouldn't be overloaded with one instrument and 2 plugins.

Do you also have constant issues with bluetooth devices? My Magic Mouse 1 and Apple keyboard constantly disconnect or become super laggy, with the mouse being the worse offender. I bought the Mini knowing about these potential issues upfront, but it's really quite annoying now that I'm living with it. Wondering if I should buy a wireless mouse instead; the ones that use the USB attachment/dongle.
At 32 buffer with those two plugins and the Logic EP I do get occasional crackles
when not using the empty audio track trick. No problem at 64 or 128.

Zero problems here with wireless Bluetooth. I hated the Apple Magic Mouse. Too many problems to list. I ended up buying a $15.00 Logitech wireless (with the USB thingy) and it works great.
Old 23rd August 2019
  #5
Oop
Gear Addict
 

Quote:
Originally Posted by tfunster View Post
Hi all,
I just got a whole new setup after my 2009 iMac died. I bought a 2018 Mini (6 core/i7/8gb RAM) and an Apogee Element 24, and purchased Logic X and am on the most current version.

I started a new project and created 1 instrument track, and added Logic's E-Piano, and 2 Soundtoys plugins, Decapitator and Little Plate. With the I/O buffer set to 32, 62 or 128, I get a core spike (maxed out) and audio crackles while playing. Setting the buffer to 256 fixes it, but then there's a bit of latency.

Is this normal? I thought my machine would be able to easily handle this. Are there any settings I can set so I can play/record with a couple of active plugins while using a small buffer size?
This seems to be some weird issue with the new Mac Mini and audio. Not sure if it's related to the T2 chip and audio buffer issues it was plagued with. I have the 2018 6-core MM with 32GB RAM and low buffer (32,64,128) playback is a hit or miss.

I've switched to a TB3 UA Apollo interface and I'm still seeing these issues and it happens on Nuendo/Ableton as well.

In Logic I've had some success keeping the buffer at 256 and then enabling low-latency mode to play/record instruments.
Old 23rd August 2019
  #6
Gear Maniac
 

Strange, I was just playing around with different display resolutions, and the CPU spike goes away when I output a full 4k and 2k, while other resolutions cause the spike to happen.
Old 25th August 2019
  #7
Gear Addict
 

Quote:
Originally Posted by tfunster View Post
Strange, I was just playing around with different display resolutions, and the CPU spike goes away when I output a full 4k and 2k, while other resolutions cause the spike to happen.
That is a great find - so it's basically the TB connection between the Mac and Apogee interface. Did you simply selected the 'Default for display' resolution rather than a scaled setting in the monitor systems preferences? Thanks!
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump