The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Logic won't recognize usb controller, please help :-o
Old 8th July 2019
  #1
Lives for gear
Logic won't recognize usb controller, please help :-o

Hey,
This issue is driving me crazy. Logic lets me use my Komplete Kontrol M32 for the transport bar functions, but not the plugin functions. Initially I thought it had something to do with the controller, but then I remembered I had the exact same problem with my Panorama P1. So it must have something to do with how I've configured Logic.

Heres what I've checked out, so far:

M32 shows up in Macs "midi studio" in utilities and seems to be connected correctly.

In Logic > Control surfaces > Setup the M32 appears in the right section lit up (without an exclamation mark, so that must be good, right?)

But it doesn't show up in Preferences > Control surfaces > Midi Controllers

With my Panorama I tried all of the uninstalling/reinstalling tips and tricks, but eventually just gave up - thinking it was Panoramas "fault". Since the exact same thing is happening with the M32, I've deduced it's a Logic/me-problem.
ps. Lates version of both firmware and Logic

If anyone can help me solve this, I will buy them beer - which can be reclaimed if we are ever in the same city at the same time.
Old 8th July 2019
  #2
Here for the gear
 
carlislesound's Avatar
Are you not able to control parameters at all or just not write automation? There's an issue with the KK software and the newest logic update in that you can't write automation from the controller. NI says they're "working on it"

But judging from the other details maybe this has been going on longer and is something else?
Attached Thumbnails
Logic won't recognize usb controller, please help :-o-kk-screenshot.png  
Old 8th July 2019
  #3
Lives for gear
No, I can't control parameters at all. On the Komplete I can press the keyboard keys (make sounds) and use the play/stop/FF/RW functionality, but the buttons labeled "browser" and "plug in midi" don't light up.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump