The No.1 Website for Pro Audio
 All  This Thread  Reviews  Gear Database  Gear for sale     Latest  Trending
Midi / Audio Timing
Old 15th May 2019
  #1
Gear Nut
 

Midi / Audio Timing

I am having trouble getting my midi synced with the audio/main playback of logic. I'm attaching a jpg to illustrate. I programmed a simple beat on an external instrument track in logic to trigger a TR-707. I recorded the playback of that into a new audio track, and as you can see, the drum hits are falling just in front of the beats. Any suggestions on how to get this lined up better when printing midi parts to audio?

Thank you!
Attached Thumbnails
Midi / Audio Timing-screen-shot-2019-05-15-2.07.05-pm.jpg  
Old 16th May 2019
  #2
Gear Maniac
There's always going to be some lag, I believe around 5ms with MIDI (less if it's USB). It's weird that it's too far forward. Perhaps Logic is computing the compensation offset incorrectly. Regardless, you can simply drag the audio within the recorded part to line up the audio, or you can use the ticks in the info section to delay it.
Old 17th May 2019
  #3
offset your midiclock delay (midi sync setting in logic) with a negative value that is reported by the audiodriver in logic.

In that way the clock is right on with the rest.

Also offset midi output in the midi settings with the same amount as the clock offset.


When you use IO plugins on a track insert a sampledelay plug with the same offset as above ( to pull AUs and HW midi on track)

At least that is how I do it
Old 28th May 2019
  #4
Lives for gear
 

If you're monitoring the 707 through the External Instrument plugin, and the 707 sounds in sync with audio coming from Logic (i.e. a click track or quantised soft synth) before & during recording, then you MUST record the 707 via a Bus.

If you don't record a software monitored synth via a Bus, your recordings will be early.
Old 30th May 2019
  #5
Gear Addict
 

Do you have plugins active on the master?
Old 5th June 2019
  #6
Gear Nut
 

Quote:
Originally Posted by DanRand View Post
If you're monitoring the 707 through the External Instrument plugin, and the 707 sounds in sync with audio coming from Logic (i.e. a click track or quantised soft synth) before & during recording, then you MUST record the 707 via a Bus.

If you don't record a software monitored synth via a Bus, your recordings will be early.
I’m not sure what you mean by recording the 707 via a bus. Like create a bus with stereo in 1/2 as the input (on my apollo twin) as the input source, then create a new audio track with that bus as the input?
Old 5th June 2019
  #7
Gear Nut
 

Quote:
Originally Posted by DanRand View Post
If you're monitoring the 707 through the External Instrument plugin, and the 707 sounds in sync with audio coming from Logic (i.e. a click track or quantised soft synth) before & during recording, then you MUST record the 707 via a Bus.

If you don't record a software monitored synth via a Bus, your recordings will be early.

Quote:
Originally Posted by arctic audio View Post
Do you have plugins active on the master?
I do not, no.
Old 5th June 2019
  #8
Gear Nut
 

My syncing issues keep getting stranger. I start a new project for each tune or beat or what have you that comes into my head. I started a new track with a battery instance, started doing some rough mixing on the drums (oxide, lex 224 reverb) then went to record some synths off the deepmind. Now instead of midi being slightly off (and ahead) it was WAY behind. OK, I added some UAD plugs, makes sense. Turn those off and the midi is STILL way behind. Take those plugins OUT of the session altogether, and midi is still WAY behind.

What am I doing wrong?

I haven’t been a logic “power” user since probably V 7 or 8 as I spent a long time focusing on bass playing and young kids, but I don’t remember having nearly half of these issues at any other point in my 19 years using logic, going back to V 4.5
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump