The No.1 Website for Pro Audio
 Search This Thread  Search This Forum  Search Reviews  Search Gear Database  Search Gear for sale  Search Gearslutz Go Advanced
Midi Behavior for External Synths Keyboard Synthesizers
Old 13th May 2018
  #1
Here for the gear
Midi Behavior for External Synths

When I set up my DSI OB6 as external instrument using the external instrument plug-in, it sounds unless I mute it, even when not selected. So if I deselect record it still plays. I'm using the midi info from the keyboard to control other external synths as well, so when I have my arp odyssey module selected I hear both instruments at once. Any ideas? I'd love any help, I've messed with the midi settings on the ob6. I've tried to play with the demix setting in Logic, the ob6 still sounds no matter what. I'm pretty new to midi protocols.
Old 14th May 2018
  #2
Unless the OB6 has a way to turn local mode off, youre just gonna have to mute it.
Old 14th May 2018
  #3
Lives for gear
in global settings. turn LOCAL CONTROL to OFF

most external synths have this. anything from DSI will

you could also assign different MIDI channels to each synth. Channel 1 for OB6, Channel 2 for the ARP etc.
Old 15th May 2018
  #4
Here for the gear
Thanks for the response, and sorry if these are obvious questions, but if I turn local off then the already recorded midi data won't be played by the ob6. I guess what I'm ultimately trying to do, and it may not be possible, is record midi data/notes, have them play a bassline or whatever on the ob 6, and then while listening to that say on a loop, play a lead line over it with the arp (using the ob6 keyboard as a midi controller for the arp). If I turn off local I won't hear the bassline. Is there no way to do this without bouncing the audio or going the old fashioned way of recording both a midi and an audio track? or without hearing both the ob6 and the arp simultaneously? I've tried putting them on separate midi channels, doesn't seem to stop the ob6 from sounding.
Old 15th May 2018
  #5
Unfortunately no. You might if it was multi-timbral, but I still dont think it will work that way. MIDI channels, at least on my system, dont even seem to matter when youre using a controller. I have 5 synths, each set to its own MIDI channel, and regardless of what my keyboard controller is set to (I use both a Microbrute and an old Oxygen 8), whatever MIDI track is selected, the keyboard plays it. Way back in Logic 4 (and maybe 5), I actually did have to change the MIDI channel on the Oxygen in order to trigger my different synths, but at some point after Apple took over and it became Logic Pro (or it might be a CoreMIDI thing), I didn't have to anymore. I can leave my controllers set to any MIDI channel I want, its still going to play whatever MIDI track I have selected regardless of its MIDI channel too.
Old 16th May 2018
  #6
Lives for gear
Quote:
Originally Posted by cobrien80 View Post
if I turn local off then the already recorded midi data won't be played by the ob6.
That's not what should happen, LOCAL OFF just kills the connection between the knobs and keyboard from sending data to the synth engine. It should still be receiving and reacting to MIDI data at the MIDI input.
Old 16th May 2018
  #7
Here for the gear
yeah that seems to be the behavior on mine as well.
Old 16th May 2018
  #8
Here for the gear
When I turn local off the synth no longer plays the previously recorded midi data, not sure why. My understanding of local control off was basically what you're describing but it isn't working for some reason.
Old 16th May 2018
  #9
Lives for gear
Quote:
Originally Posted by cobrien80 View Post
When I turn local off the synth no longer plays the previously recorded midi data, not sure why. My understanding of local control off was basically what you're describing but it isn't working for some reason.

are we talking midi data recorded to the OB6's sequencer? Or MIDI from your daw?
Old 17th May 2018
  #10
Here for the gear
from the daw, now I seem to be able to get it to behave correctly half the time, and then suddenly the ob6 just stops playing the midi notes, if I restart it it will sound, so maybe local midi off is the correct solve. Thanks for that. Not sure why it goes mute half the time or after a while. Doesn't seem to happen when local midi control is on. Thank you for all the help, I'll keep messing with it, maybe it's an issue with the ob6
Old 17th May 2018
  #11
Here for the gear
reached the crux of the problem, not a solve, but circling it. Seems to be a well documented issue with midi hanging the ob6. See below if curious. Thanks for all the advice

https://forum.davesmithinstruments.c...?topic=1034.20
Old 19th May 2018
  #12
Lives for gear
Quote:
Originally Posted by cobrien80 View Post
reached the crux of the problem, not a solve, but circling it. Seems to be a well documented issue with midi hanging the ob6. See below if curious. Thanks for all the advice

https://forum.davesmithinstruments.c...?topic=1034.20
ah i see. MIDI over USB can get funky.
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump