The No.1 Website for Pro Audio
"The plug-in named ... isn't available"
Old 5th May 2017
  #1
Here for the gear
 

"The plug-in named ... isn't available"

When opening a project in Logic Pro X (10.3.1), I receive a message: 'The plug-in named "Abbey Road " isn't available on your system.' This is repeated in relation to plug-ins referred to as "PuigChild 6" and "SoundShifte".

When the project opens, instances of the plug-ins referred to appear greyed out and with a white exclamation mark in an orange circle.

I have tried the rescan procedure set out at How to Find Your Plugins in Logic Pro X | Support | Waves - only up to step 2(g) because the plug-ins referred to in the messages are not shown in the Plug-ins Manager. However, the problem remains.

Each of the plug-ins referred to are by Waves. I do not know whether it is significant, but the names used for the plug-ins in the messages differ from the names used by Waves. The reference to "Abbey Road " (I note the space between 'Road' and the quotation marks) is to the 'Abbey Road Reverb Plates' and the bundle for this plugin is named 'ARPlates.bundle'. The reference to "PuigChild 6" is to the 'PuigChild Compressor', with a bundle named 'PuigChild.bundle'; and the reference to "SoundShifte" is to 'SoundShifter' (with an 'r'), which has a bundle named 'SoundShifter.bundle'.

I have not been able to use the names as shown in the messages as a Custom Name or Short Name in Plug-in Manager (as per 'Shortened Plugin Names' at https://www.logicprohelp.com/forum/v...ilable#p647920) because, as noted above, the plug-ins referred to are not shown there.

I have tried the approach described in 'A plugin named "Massive isn't available" message - solution' (at https://www.logicprohelp.com/forum/v...%27t+available) and have reinstalled all of the Waves plug-ins through the Waves installer, but without success.

Each of the bundles for the plug-ins referred to above is shown in System HD (in my case, 'Macintosh HD') > Applications > Waves > Plug-Ins V9.
'Waveshell-AU 9.91.component' is shown in System HD (in my case, 'Macintosh HD') > Library > Audio > Plug-Ins > Components.

Can anyone please advise about how to have Logic Pro X recognise these plug-ins? Any assistance would be greatly appreciated.
Old 5th May 2017
  #2
Lives for gear
 

What happens if you try opening a brand new empty Logic project?
Can you load the Waves plugins?

How old is the project you're trying to open? It might be looking for older versions of the Waves plugs.

If you have reinstalled the Waves plugs and they're all properly authorised in the Waves Central app, you could also try deleting your Audio Units cache:

In the Finder, choose Go > Go to Folder from the menu.
Type ~/Library/Caches in the "Go to the folder" field.
Press the Go button
Remove the "com.apple.audiounits.cache" file.
Remove the ~/Library/Caches/AudioUnitCache folder
Old 5th May 2017
  #3
Here for the gear
 

Thank you Hint for your response.

The project is about 10 months old but when I create a new empty project, the plug-ins referred to in the message still cannot be loaded as they are not shown on the drop down menu and do not appear in the Plug-In Manager.

I have now also compared all of the bundles in 'HD>Applications>Waves>Plug-Ins V9' with the Waves plug-ins shown in the Logic Pro X Plug-In Manager and have found that there are other Waves plug-ins missing.

I have deleted the AudioUnitCache folder and 'com.apple.audiounits.cache' a number of times, in combination with the Waves Preferences folder and use of the Waves AU Reg Utility. All of the plug-ins have been reinstalled via Waves Central which shows that there is a 'Full License' for each (and there is a bundle for each in 'HD>Applications>Waves>Plug-Ins V9').

I'm a bit stumped but am still searching. When I reinstalled the plug-ins, I used the 'Repair' option in Waves Central, which is said to 'Reinstall your Waves products on this computer'. I may attempt to purge my system of all things 'Waves' and then try reinstalling again.

Thanks again for your suggestions.
Old 6th May 2017
  #4
Here for the gear
 

In my searches, I've found that this issue is occurring with Waves plug-ins on other DAWs. As it seems to be a 'Waves' issue, I'll pursue solutions elsewhere. Cheers.
Old 3 weeks ago
  #5
Here for the gear
 

Same issue still to be fixed.

What just happened to me is that I bought a new MacBook Pro Created a user account Used time machine to transfer my main computer HD image creating a new user Identical to my main working computer into my new Macbook Pro. So I have two user admin that I am playing with to see differences. I used public>dropbox to bring all folders to the fresh user account in order to create a similar environment The result is that when I open Logic X in my user clone I have all plug-ins working besides one When I login the fresh Account Logic doesn’t recognize 30% of the plug-ins which are working perfectly in the other user account I’ve tried everything to make them work but I really don’t understand the reason why they wouldn’t work I obviously reinstalled a few of them to see how the system would react. It didn’t work out. Please help.
Topic:
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Forum Jump
Forum Jump