The No.1 Website for Pro Audio
Midas VeniceF-series
Old 21st June 2020
  #991
Lives for gear
 
CarLofgren's Avatar
 

Quote:

1. Uninstall the current firmware.

2. Boot into OS X Utilities window, turn off SIP in Terminal and restart the machine.

3. Install the FW software again.

4. Boot into OS X Utilities window, turn on SIP

You should now be able to see the device in the Midas software.

Sorry for the inconvenience caused by this but as mentioned previously, this is a Legacy product."



Restart your Mac.
Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
From the Utilities menu, select Terminal.
At the prompt type exactly the following and then press Return: csrutil disable
Terminal should display a message that SIP was disabled.
From the  menu, select Restart.
You can re-enable SIP by following the above steps, but using csrutil enable instead.
I saved some text from some important posts that helped me. Maybe it will help you.

/C
Old 21st June 2020
  #992
Here for the gear
 

Quote:
Originally Posted by CarLofgren View Post
I saved some text from some important posts that helped me. Maybe it will help you.

/C
Amazing, thank you so much! It works now :^)
little note about the adapters: the fw 800 —> tb2 is by apple while the fw 400 —> 800 is a third party product. looks like this wasn't part of the problem
Old 22nd June 2020
  #993
Gear Addict
 

Quote:
Originally Posted by CarLofgren View Post
I saved some text from some important posts that helped me. Maybe it will help you.

/C
Thanks, C.
Old 22nd June 2020
  #994
Gear Addict
 

Quote:
Originally Posted by rrraoul View Post
Amazing, thank you so much! It works now :^)
little note about the adapters: the fw 800 —> tb2 is by apple while the fw 400 —> 800 is a third party product. looks like this wasn't part of the problem
@ rrraoul which driver did you use? there are 2 different ones on the Midas website: Driver for OSX (4.2.1) and FireWire Driver for Mac.
Old 22nd June 2020
  #995
Here for the gear
 

Quote:
Originally Posted by kwazi View Post
@ rrraoul which driver did you use? there are 2 different ones on the Midas website: Driver for OSX (4.2.1) and FireWire Driver for Mac.
I used the Driver for OSX
Old 22nd June 2020
  #996
Gear Addict
 

Quote:
Originally Posted by rrraoul View Post
I used the Driver for OSX
Thanks!
Old 26th June 2020
  #997
Here for the gear
 

Hello there guys,

I've just purchased the VF24. Unfortunately midasconsoles.com seems to be down which gives me no way to download the much needed drivers. Is there anyone who could make me a HUGE favour and send me the drivers? I'm on Mac, El Capitan.

Any help is much appreciated. I'll buy potential helpers lots of beer if you're ever in Helsinki, Finland.
Old 26th June 2020
  #998
Gear Head
 
kings's Avatar
 

You guys need to disable SIP and keep it disabled...
Old 26th June 2020
  #999
Here for the gear
 

Quote:
Originally Posted by PizzoGinori View Post
Hello there guys,

I've just purchased the VF24. Unfortunately midasconsoles.com seems to be down which gives me no way to download the much needed drivers. Is there anyone who could make me a HUGE favour and send me the drivers? I'm on Mac, El Capitan.

Any help is much appreciated. I'll buy potential helpers lots of beer if you're ever in Helsinki, Finland.
Sorted.
Old 26th June 2020
  #1000
Here for the gear
Quote:
Originally Posted by kings View Post
You guys need to disable SIP and keep it disabled...
What’s the use disable sip, if everything’s running fine⁉️
Old 26th June 2020
  #1001
Here for the gear
 

Got the drivers sent to me. Tried both of them but no luck. I also tried disabling sip. Has anyone experienced similar problems? I'm running El Capitan on a late 2012 iMac.
Old 26th June 2020
  #1002
Lives for gear
 
mutetourettes's Avatar
 

If you followed those instructions to the letter then your next stop I’d recommend is trying different computer, and or different cable/adapter. Basically I wouldn’t declare the fw card dead until i’d tried it in a lot of ways (unless it was working for you before). Thought mine was dead until i tried it on an ancient macbook g4 and it worked fine! Then had to find a better fw card for my pc until it worked there too. People do get better luck with official Mac adapters.. try some variations..
Old 26th June 2020
  #1003
Here for the gear
 

Quote:
Originally Posted by mutetourettes View Post
If you followed those instructions to the letter then your next stop I’d recommend is trying different computer, and or different cable/adapter. Basically I wouldn’t declare the fw card dead until i’d tried it in a lot of ways (unless it was working for you before). Thought mine was dead until i tried it on an ancient macbook g4 and it worked fine! Then had to find a better fw card for my pc until it worked there too. People do get better luck with official Mac adapters.. try some variations.. ������
Yep. Tried an fw400 to fw800 cable - apple fw800 to tb2 adapter as well as fw400 cable - fw800 adapter - apple fw800 to tb2 apple adapter.
Haven't had any trouble using the same cables/computer with my RME800 and RME802. I'll try a different computer next. Thanks a lot! I really appreciate all help.
Old 28th June 2020
  #1004
Here for the gear
 

After further investigation it seems like I've got the wrong drivers. Has anyone got the Venice F Mac OS X Firewire Driver Version G4.2.0 (07 January 2016)? That seems to be the one I need but I can not find it anywhere, especially since the midasconsoles.com page is down. Thanks again.

edit: I managed to get through to the midasconsoles.com download section. Seems like they've got El Capitan compatible drivers for the VF32 but not for the VF24. Is this really the case?
Old 28th June 2020
  #1005
Lives for gear
 
mutetourettes's Avatar
 

Quote:
Originally Posted by PizzoGinori View Post
I managed to get through to the midasconsoles.com download section. Seems like they've got El Capitan compatible drivers for the VF32 but not for the VF24. Is this really the case?
I think they're all the same driver - it doesn't care which model of desk you connect up. In fact some folk have connected two desks on the same firewire and it sees a huge desk....
Old 30th June 2020
  #1006
Here for the gear
 

Quote:
Originally Posted by mutetourettes View Post
I think they're all the same driver - it doesn't care which model of desk you connect up. In fact some folk have connected two desks on the same firewire and it sees a huge desk....
Tried it without any luck. Very frustrating. Maybe I have to install an old operating system..
Old 10th July 2020
  #1007
Here for the gear
 

I think I've tried everything now. Four different operating systems, all the drivers, disabling/enabling SIP. Also tried with my old macbook with FW, so no adapters.
This leads me to believe the FW card has blown. Where can I buy a new one? Is it possible?
Old 22nd July 2020
  #1008
Lives for gear
 
CarLofgren's Avatar
 

Sadly I have to second this. I've also spent about a day trying to get the Venice to work with my new MacMini and no matter what I do the driver doesn't see the Venice. The Apple System info sees it though - but the driver not.

I don't know how I managed to make it work before - maybe some security update cut off the last connection with the driver and the hardware. But now it's completely unrecognised.

I hooked it up though to my slightly older Macbook Pro and there it worked just fine. So at least I know there isn't the Venice malfunctioning. Personally it's not a big deal - I can do the recording to the Macbook. But damn annoying I can't get the MacMini to work with it again.

/Carl
Old 27th July 2020
  #1009
Here for the gear
 

Dang.... that sucks to hear. Would downgrading the OS help? After following your SIP advice I was able to get the Venice running on my Catalina MacMini. Or how about installing a virtual machine? It's a bit of a pain but that way you might be able to record in the oler OS and then drop it into the newer OS for editing. Just my two cents.
Quote:
Originally Posted by CarLofgren View Post
Sadly I have to second this. I've also spent about a day trying to get the Venice to work with my new MacMini and no matter what I do the driver doesn't see the Venice. The Apple System info sees it though - but the driver not.

I don't know how I managed to make it work before - maybe some security update cut off the last connection with the driver and the hardware. But now it's completely unrecognised.

I hooked it up though to my slightly older Macbook Pro and there it worked just fine. So at least I know there isn't the Venice malfunctioning. Personally it's not a big deal - I can do the recording to the Macbook. But damn annoying I can't get the MacMini to work with it again.

/Carl
Old 27th July 2020
  #1010
Here for the gear
 

Tracking Issues

Sorry to diverge again. Has anybody had tracking issues with the Midas F? Recently it's been choking on me while recording.

Sounds like this:https://soundcloud.com/bsbeuys/****up/s-Z1egsoVwNJK

looks like this: https://photos.google.com/share/AF1Q...hOcXdkbWdIczhn

It happened while recording around 14 tracks at the same time but it doesn't always happen. It's not a MIDI issue. For a second I thought it might be my MacMini not being able to keep up but I monitored the CPU use and it rarely exceeds 30%.

Anybody have an idea how to find / fix this problem?

thanks!
Old 3rd August 2020
  #1011
Here for the gear
 

I have a feeling that Catalina 10.15.6 update has prevented the possibility to run the driver with SIP enabled. Once I disable SIP I see the desk and can work with it as usual. But only until I enable it again.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 52 views: 12081
Avatar for BenJah
BenJah 25th September 2008
replies: 146 views: 48207
Avatar for Aidanr2012
Aidanr2012 12th May 2020
replies: 1296 views: 149547
Avatar for heraldo_jones
heraldo_jones 1st February 2016
replies: 182 views: 28633
Avatar for cory508
cory508 2 weeks ago
Post Reply

Welcome to the Gearslutz Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…
🖨️ Show Printable Version
✉️ Email this Page
🔍 Search thread
🎙️ View mentioned gear
Forum Jump
Forum Jump