Cubase 5 MIDI playback staggered and choppy?
Old 29th October 2012
  #1
Gear addict
 

Thread Starter
Cubase 5 MIDI playback staggered and choppy?

Hi all

Similar thread to an earlier one but things have changed.
I have an issue since I reinstalled all of my software.
I'm having problems with my MIDI playback being terribly choppy.
I have an i7 based system which is years ahead of the system spec requirements.
I'm also running Cubase 5.
I threw a beat down on BFD but playback is so choppy it sounds random.
I thought it was BFD so I reinstalled it, same problem.
So I thought I'd use Battery 3 in the meantime but the exact same problem with Battery.
So just to double check, I threw a sequence down with one of the basic VST synths that come with Cubase. Same problem, and those synths are tiny?
Please help, this is so frustrating!
Old 29th October 2012
  #2
Lives for gear
 
shanabit's Avatar
 

1. What MIDI interface?
2. Audio I/O box your using?
3. Audio buffer setting?
4. Snap on or off and what settings?
Old 29th October 2012
  #3
Gear addict
 

Thread Starter
Quote:
Originally Posted by shanabit View Post
1. What MIDI interface?
2. Audio I/O box your using?
3. Audio buffer setting?
4. Snap on or off and what settings?
1. Tascam US-144
2. Tascam US-144
3. Audio priority, normal?
4. Absolutely no idea what you're talking about.

I didn't think the interface was relevant? Nothing is going in or out of it.
Funny thing is, I'm watching battery 3 and there is an indicator to show midi input, and it is flashing in correspondence with the random sounds I'm hearing.
But the midi out on the cubase track is corresponding the beat I wrote down.
There is a miscommunication between cubase and battery/bfd.
Old 30th October 2012
  #4
Lives for gear
 
shanabit's Avatar
 

Quote:
Originally Posted by bruvvamoff View Post
1. Tascam US-144
2. Tascam US-144
3. Audio priority, normal?
4. Absolutely no idea what you're talking about.

I didn't think the interface was relevant? Nothing is going in or out of it.
Funny thing is, I'm watching battery 3 and there is an indicator to show midi input, and it is flashing in correspondence with the random sounds I'm hearing.
But the midi out on the cubase track is corresponding the beat I wrote down.
There is a miscommunication between cubase and battery/bfd.
1. Do you have the latest drivers for your Tascam??
2. Do you have the quantize turned on? Snap ON or OFF and what is the quantize value set to?
3. Are you running all of this from your OS Drive which has Windows on it?
You should have a separate drive for Sample streaming.

**Your midi sloppiness has a direct correlation with the AUDIO buffer setting of your Tascam. The bigger the buffer setting the more slop.
Old 30th October 2012
  #5
Gear addict
 

Thread Starter
Quote:
Originally Posted by shanabit View Post
1. Do you have the latest drivers for your Tascam??
2. Do you have the quantize turned on? Snap ON or OFF and what is the quantize value set to?
3. Are you running all of this from your OS Drive which has Windows on it?
You should have a separate drive for Sample streaming.

**Your midi sloppiness has a direct correlation with the AUDIO buffer setting of your Tascam. The bigger the buffer setting the more slop.
Yes, latest Tascam drivers.
I still don't understand what the Tascam has to do with anything?
The midi information being sent from cubase to battery is getting messed up.
It's almost like there is a randomizer effect on it.
When I play beats on my midi controller, there is no lag.
When I write them and play back, lag and chop.
Old 30th October 2012
  #6
Gear addict
 

Thread Starter
OK I managed to find the audio buffer settings.
They were on 2048 in and out so I made them 512 in and out and it's greatly improved but it's still not perfect.
Regular stutters and slops.
Old 30th October 2012
  #7
Lives for gear
 
valis's Avatar
Are you clocked to something external for sync? SMPTE?
Old 30th October 2012
  #8
Gear addict
 

Thread Starter
Quote:
Originally Posted by valis View Post
Are you clocked to something external for sync? SMPTE?
My only external hardware is my Tascam us144.
What does clocked mean?
Old 31st October 2012
  #9
Gear addict
 

Thread Starter
I must bump. Playback on audio and midi is fine but every 20 seconds or so I get a small period of choppy playback where everything goes crazy for 10 seconds.
Old 1st November 2012
  #10
Gear addict
 

Thread Starter
Also during this choppy period I get the processing icon on my mouse pointer.
Please help, I have some lovely outboard coming this weekend and I wanted to record some demos.
Old 3rd November 2012
  #11
Gear interested
Did U find a solution?

Don't know if it's same as your issue but, when I had similar symptoms, I discovered my Sequencer was echoing MIDI data back to my External Synth. i.e. My Sequencer (Cubase) was set for 'Pass Thru' on MIDI data.

My Synth, after receiving this Cubase MIDI data would echo audio of the same MIDI notes being played by my VST/Plugin in Cubase.

I don't think this would cause your Battery 3 Plugin to indicate renegade MIDI notes though-- possible but I believe your Audio would have gone berserk if such a loop was taking place.

Just an experience I had! :-)
Old 3rd November 2012
  #12
Gear addict
 

Thread Starter
Quote:
Originally Posted by MoBuc View Post
Don't know if it's same as your issue but, when I had similar symptoms, I discovered my Sequencer was echoing MIDI data back to my External Synth. i.e. My Sequencer (Cubase) was set for 'Pass Thru' on MIDI data.

My Synth, after receiving this Cubase MIDI data would echo audio of the same MIDI notes being played by my VST/Plugin in Cubase.

I don't think this would cause your Battery 3 Plugin to indicate renegade MIDI notes though-- possible but I believe your Audio would have gone berserk if such a loop was taking place.

Just an experience I had! :-)
Interesting. Thanks for letting me know, at least I know what to look for if that happens.
It turned out that my audio buffer was set too high (612) and my ASIO driver was incorrect.
All good now, only problem is my buzzing speakers.
(that's on my other thread if you have any ideas)
Old 4 Weeks Ago
  #13
Gear Head
 

Quote:
Originally Posted by bruvvamoff View Post
OK I managed to find the audio buffer settings.
They were on 2048 in and out so I made them 512 in and out and it's greatly improved but it's still not perfect.
Regular stutters and slops.
I'm very confused here... isn't a higher buffer size supposed to reduce the choppy effect? I would think the lower you set it, the worse it'll be...
Topic:
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
Pronecobra / Music Computers
3
fontenele / Music Computers
1
KeengCong / Rap + Hip Hop engineering & production
2
zemlin / Remote Possibilities in Acoustic Music & Location Recording
10

Forum Jump
 
Register FAQ Search Today's Posts Mark Forums Read

SEO by vBSEO ©2011, Crawlability, Inc.