Which Discontinued NI VI's still work OK on Windows 7?
thehightenor
Thread Starter
#1
17th December 2011
Old 17th December 2011
  #1
Lives for gear
 
Joined: Nov 2011
Posts: 1,057

Thread Starter
Which Discontinued NI VI's still work OK on Windows 7?

Before I pull the trigger on Komplete 8 (I'd rather not!)

Does anyone have any of the following Legacy NI VI's working with Windows 7

I'm running Cubase 6 (32 bit) on Windows 7 (64 bit)

I have the following discontinued NI VI's:

1. Reaktor Session
2. B4
3. FM7
4. Pro 53

In this economic climate, I'd really like to continue using these VI's without having to upgrade. My Cubase 6 rig is very stable and I wondered if anyone is running these above discontinued NI VI's successfully and without any crashes?

Thanks
tht
#2
17th December 2011
Old 17th December 2011
  #2
Gear addict
 
mutilatedlip's Avatar
 
Joined: Mar 2009
Posts: 313
My Studio

Hi there

I'm using Pro 53, FM7 and B4 on Windows 7 64 Bit with Cubase 6.

I've had absolutely no issues.

However, I do use jBridge as I find the Cubase bridge to be a little unstable at times.
thehightenor
Thread Starter
#3
17th December 2011
Old 17th December 2011
  #3
Lives for gear
 
Joined: Nov 2011
Posts: 1,057

Thread Starter
Quote:
Originally Posted by mutilatedlip View Post
Hi there

I'm using Pro 53, FM7 and B4 on Windows 7 64 Bit with Cubase 6.

I've had absolutely no issues.

However, I do use jBridge as I find the Cubase bridge to be a little unstable at times.
Thanks for your reply, that sounds promising.

I wouldn't need a bit bridge as I'm using Cubase 6 32 bit and my NI VI's are 32 bit as well - unless I am misunderstanding something here.

tht
#4
17th December 2011
Old 17th December 2011
  #4
Lives for gear
 
famousbass's Avatar
 
Joined: May 2011
Location: Sydney
Posts: 1,549

Cubase in Mac.
They all work (except no idea about Reaktor Session though, never heard of it).
They only thing that never worked in Mac Cubase is B4II as an in insert fx.
However it does work if you wrap it through Kore.
#5
17th December 2011
Old 17th December 2011
  #5
Lives for gear
 
greggybud's Avatar
 
Joined: Dec 2004
Location: Eugene Oregon
Posts: 1,636

Quote:
Originally Posted by thehightenor View Post
Before I pull the trigger on Komplete 8 (I'd rather not!)

Does anyone have any of the following Legacy NI VI's working with Windows 7

I'm running Cubase 6 (32 bit) on Windows 7 (64 bit)

I have the following discontinued NI VI's:

1. Reaktor Session
2. B4
3. FM7
4. Pro 53

In this economic climate, I'd really like to continue using these VI's without having to upgrade. My Cubase 6 rig is very stable and I wondered if anyone is running these above discontinued NI VI's successfully and without any crashes?

Thanks
tht
I run Windows 7 64 with Cubase 6 32 inside it. No bridges.

All of those should work fine.

Really, I think the easier question to ask these days is what VI's DO NOT WORK with Windows 7 on a PC that worked on XP?

This much spread forum myth, usually offered in the hardware vs software debate, suggests when you upgrade to a new operating system all your old applications suddenly become useless.

However it's interesting you rarely see this same comment when reading the endless PC vs Mac debates. I can only assume this myth got started because of frustrated Mac owners who often can't run old software on their new operating systems.
#6
17th December 2011
Old 17th December 2011
  #6
Gear addict
 
mutilatedlip's Avatar
 
Joined: Mar 2009
Posts: 313
My Studio

Many apologies! Perhaps I should read posts properly...

You shouldn't have any issues at all-the NI stuff is all compatible.
#7
17th December 2011
Old 17th December 2011
  #7
3 + infractions, forum membership suspended.
 
Joined: Jul 2010
Location: Los Angeles
Posts: 2,527

I also use jBridge to bridge all my 32-bit plugs in Cubase 6 x64. Much better than Cubase's own vstbridge. I still have many Ueberschall Liquid libraries I occasionally use and Liquid is a discontinued VSTi that hasn't been updated in at least 5 years (and never will be, since Ueberschall switched to Elastik, which, unfortunately, does not load Liquid libraries.) Vstbridge can't handle it (it crashes Cubase miserably) but it's absolutely no problem for jBridge. Amazing. Just for kicks, I tried to bridge some other really old VST's and the result is almost always the same: vstbridge crashes the DAW, jBridges handles it without issues.
#8
17th December 2011
Old 17th December 2011
  #8
3 + infractions, forum membership suspended.
 
Joined: Oct 2008
Posts: 6,338

To be sure you can run installer in xp compatibilty mode ...
thehightenor
Thread Starter
#9
19th December 2011
Old 19th December 2011
  #9
Lives for gear
 
Joined: Nov 2011
Posts: 1,057

Thread Starter
Thanks for all the excellent replies.

The only VST instruments I have had definite problems with is Steinberg's Virtual Guitarist 1 and the Electric Edition. I know VG 2 works OK on W7, but I cannot get W7 to work with VG1. Has anyone got those two VI's to work under W7? Being primarily a pianist I really miss them, they were so useful and cost me both together £300! It is a real shame to have them sat there doing nothing.

Maybe I should try XP compatibility mode?

Thanks
That
#10
22nd December 2011
Old 22nd December 2011
  #10
Gear Head
 
somehowsomeway's Avatar
 
Joined: Nov 2011
Location: Salt Lake City, UT
Posts: 28

B4 II works great

underground is the sound
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
kineticfs / Newbie audio engineering & production question zone
2
Seamus TM / Studio building / acoustics
2

Forum Jump
 
Register FAQ Search Today's Posts Mark Forums Read

SEO by vBSEO ©2011, Crawlability, Inc.