Focusrite Liquid Mix 32 ... why doesn't everyone have one?
#91
22nd December 2010
Old 22nd December 2010
  #91
Lives for gear
 
kafka's Avatar
 

I had all the usual issues with my LM. Because of the constant problems, it's fallen in and out of favor a number of times. First there were the driver issues, and then there was the bass issue, and then more driver issues. Lack of ADC on PT was always a problem. I guess I'm one of the few people who think Mellowmuse is a pretty decent solution, so that's solved for me now. And then there was the latest issue where only one instance would work at a time, although that has also been solved.

I think the LM concept is really good. It's useful and convenient, and it does sound pretty good. That said, every time some problem cropped up it just became incentive to drop it and find some other way to work. I now use UAD a lot more, and in just about every case it sounds better.

I'm kind of disappointed Focusrite gave up on it. If it worked as well when it was first released as it does now, I'm pretty sure it wouldn't have been discontinued. I think it's a good example of the risks of rushing a product to market and expecting your customer base to beta test.
#92
22nd December 2010
Old 22nd December 2010
  #92
Lives for gear
 

Quote:
Originally Posted by RoyalRichmen View Post
It seems that everybody has a different problem with the unit.

I have had no problems
#93
24th December 2010
Old 24th December 2010
  #93
Gear addict
 

I had an LM32 and could never get it to run stable in either sonar or reaper. The problems were most likely due to a combination of dodgy drivers and the fact I was using a firewire interface ( I installed a separate fw card for it but it made no difference.)

To be honest I was happy to get rid of it. I've got uad cards now and they don't give any trouble whatsoever
#94
25th December 2010
Old 25th December 2010
  #94
Focusrite Liquid Mix 32 ... why doesn't everyone have one?

Can someone Tell me more about the Bass issue? On the british5 Emu the LowCut is very Strong. Also on some Otters. Is it that, what is meant by Bass issue? Or something Else? Is it fixed in V3?
#95
25th December 2010
Old 25th December 2010
  #95
Lives for gear
 
Mardi Gras's Avatar
 

I got a liquid mix for christmas today, I asked for a 32 but my dad got me the 16... oh well lololol
#96
25th December 2010
Old 25th December 2010
  #96
Lives for gear
Quote:
Originally Posted by Mardi Gras View Post
I got a liquid mix for christmas today, I asked for a 32 but my dad got me the 16... oh well lololol
Probably saw it was cheaper and thought SCORE! haha...
#97
25th December 2010
Old 25th December 2010
  #97
Lives for gear
 
Mardi Gras's Avatar
 

Quote:
Originally Posted by Nelson89 View Post
Probably saw it was cheaper and thought SCORE! haha...
i know, i was like 'make sure its a 32' the fool!
#98
25th December 2010
Old 25th December 2010
  #98
Lives for gear
 
icecubeman's Avatar
Quote:
Originally Posted by Mardi Gras View Post
i know, i was like 'make sure its a 32' the fool!
I dont understand, why you let your daddy buy this kind of things for you. Even on Christmas. tutt
#99
25th December 2010
Old 25th December 2010
  #99
Lives for gear
Quote:
Originally Posted by icecubeman View Post
I dont understand, why you let your daddy buy this kind of things for you. Even on Christmas. tutt
haha yeh...for the past 2 years my father hasn't given me one present...just money instead, cause he's got NO idea what to buy when it comes to musical gear....
#100
25th December 2010
Old 25th December 2010
  #100
Lives for gear
 
Mardi Gras's Avatar
 

Quote:
Originally Posted by icecubeman View Post
I dont understand, why you let your daddy buy this kind of things for you. Even on Christmas. tutt
is that inferring the liquid mix is shit?
#101
25th December 2010
Old 25th December 2010
  #101
Lives for gear
 
icecubeman's Avatar
Quote:
Originally Posted by Mardi Gras View Post
is that inferring the liquid mix is shit?
I am very happy user of LM. It is great sounding box. I just dont understand why you didnt buy the right piece yourself.
#102
25th December 2010
Old 25th December 2010
  #102
Lives for gear
 
Mardi Gras's Avatar
 

Quote:
Originally Posted by icecubeman View Post
I am very happy user of LM. It is great sounding box. I just dont understand why you didnt buy the right piece yourself.
Oh, because he asked me what i wanted for christmas and I said a LM32.. lol.
#103
25th December 2010
Old 25th December 2010
  #103
Gear addict
 
russellwolff's Avatar
it is discontinued

might seem obvious to some... but maybe he got the 16 since the 32 was discontinued. from a parent perspective, that was the responsible choice to make.

you can always trade it for a 32 on the used market. but either way, you are in the game now. grab a used expansion card and double your pleasure...

Quote:
Originally Posted by Mardi Gras View Post
Oh, because he asked me what i wanted for christmas and I said a LM32.. lol.
#104
25th December 2010
Old 25th December 2010
  #104
Lives for gear
 
kafka's Avatar
 

If I were you I'd stick with the 16 and let it go at that. I never use even 16 channels of LM, let alone 32.
#105
25th December 2010
Old 25th December 2010
  #105
Focusrite Liquid Mix 32 ... why doesn't everyone have one?

I always Need or use all 32. The Most instances are used for Bus channels. I would bring it back and buy the 32.

Can someone give some insight about my question:
Can someone Tell me more about the Bass issue? On the british5 Emu the LowCut is very Strong. Also on some Otters. Is it that, what is meant by Bass issue? Or something Else? Is it fixed in V3?
#106
25th December 2010
Old 25th December 2010
  #106
Lives for gear
 
Mardi Gras's Avatar
 

just checking in here. The LM16 obviously has been bought from america and has come with an american plug socket...... With me living in the UK will the american version still work if I use a plug converter?

Going to need a firewire 400/800 cable too, fml
#107
27th December 2010
Old 27th December 2010
  #107
Lives for gear
 
kafka's Avatar
 

Quote:
Originally Posted by RoyalRichmen View Post
Can someone give some insight about my question:
Can someone Tell me more about the Bass issue? On the british5 Emu the LowCut is very Strong. Also on some Otters. Is it that, what is meant by Bass issue? Or something Else? Is it fixed in V3?
Liquid mix v2.x bass bug!!

Quote:
Originally Posted by Mardi Gras View Post
just checking in here. The LM16 obviously has been bought from america and has come with an american plug socket...... With me living in the UK will the american version still work if I use a plug converter?
Don't use the power adapter. Just power it off the firewire.
#108
5th January 2011
Old 5th January 2011
  #108
Thanks for the Link to the buss bugs.
In a German Forum I read that the following emulations are unusable in the LowEnd. These one:
BRIT-DESK 4,5,6 (SSL Emulationen and Angela Emulation)
CLASS A2 (Neve 1073 Emulation)
FOCUSRITE ISA 115
PLATINUM 1

AND these are usable
ZEBRA 2,3 (Chandler Limited Passiv TG...)
SILVER 2 (Avalon 737 Emulation)

can anybody confirm this?
#109
5th January 2011
Old 5th January 2011
  #109
Gear addict
 
Markus Stock's Avatar
 

Focusrite Liquid Mix 32 ... why doesn't everyone have one?

You mean the Low Cut not the Low End in general. Just use your ears. Some of the Low Cuts are cutting really high (at around 200-300 Hz) as oppossed to what Liquid Mix is telling you but you will hear that. I don't use any Low Cuts in LM.
#110
6th January 2011
Old 6th January 2011
  #110
Lives for gear
 
Big_Bang's Avatar
 

Hasn't this been completely fixed with the latest updates?

Pretty sure they have, though to be honest, I haven't dwelled into EQ in the LM for quite some time now
#111
6th January 2011
Old 6th January 2011
  #111
Lives for gear
 
icecubeman's Avatar
Quote:
Originally Posted by RoyalRichmen View Post
Thanks for the Link to the buss bugs.
In a German Forum I read that the following emulations are unusable in the LowEnd. These one:
BRIT-DESK 4,5,6 (SSL Emulationen and Angela Emulation)
CLASS A2 (Neve 1073 Emulation)
FOCUSRITE ISA 115
PLATINUM 1

AND these are usable
ZEBRA 2,3 (Chandler Limited Passiv TG...)
SILVER 2 (Avalon 737 Emulation)

can anybody confirm this?
Neve 1073 emulation is usable on all bands. It is one of the best emulation of LM. With SSL emulations it is true, not usable. But you can check for this for yourself. Just diownload this software, load vst plugin and run test. KVR: Christian Budde VST Plugin Analyser - Plug-in Host

Pultecs, API and EAR are also great and fully usable!!!
#112
7th January 2011
Old 7th January 2011
  #112
Gear Head
 

Quote:
Originally Posted by icecubeman View Post
Neve 1073 emulation is usable on all bands. It is one of the best emulation of LM. With SSL emulations it is true, not usable. But you can check for this for yourself. Just diownload this software, load vst plugin and run test. KVR: Christian Budde VST Plugin Analyser - Plug-in Host

Pultecs, API and EAR are also great and fully usable!!!
It is not anymore available.
#113
7th January 2011
Old 7th January 2011
  #113
Lives for gear
 
icecubeman's Avatar
#114
13th January 2011
Old 13th January 2011
  #114
Gear addict
 
russellwolff's Avatar
just in case someone here knows...

LIQUID MIX USERS: How to setup default snapshot that loads every time?

I used to know how to do this, but cannot find it again after looking through forums and the manual (although I admit to a serious case of ADD)

There is a way to have LM setup so that every time you open an instance of the plugin in ProTools, your favorite EQ and COMP patches are there by default.

Anyone remember how to do this?

thanks!
#115
18th January 2011
Old 18th January 2011
  #115
Gear addict
 
russellwolff's Avatar
focusrite wrote back to me and said there is no way to do this. i was pretty sure there was... oh well.
#116
22nd January 2011
Old 22nd January 2011
  #116
Focusrite Liquid Mix 32 ... why doesn't everyone have one?

Quote:
Originally Posted by russellwolff
focusrite wrote back to me and said there is no way to do this. i was pretty sure there was... oh well.
Don't have my Mbox here, so I can't Rey it. All I know is, how to do it in Logic and maybe this helps you. In Logic I Save my settings in the Logic Plugin Window As #Default. This Works for all plugs and also the LM.
#117
12th February 2011
Old 12th February 2011
  #117
Gear Head
 

I'm loving mine again with pro tools 9. ADC. Greatest. Addition. Ever.
#118
12th February 2011
Old 12th February 2011
  #118
Gear addict
 
russellwolff's Avatar
are you using the plugins while tracking or just mixing?

what settings in your PT 9 Playback Engine options? (buffers, etc)

Quote:
Originally Posted by ThePhil View Post
I'm loving mine again with pro tools 9. ADC. Greatest. Addition. Ever.
#119
12th February 2011
Old 12th February 2011
  #119
Gear Head
 

Quote:
Originally Posted by russellwolff View Post
are you using the plugins while tracking or just mixing?

what settings in your PT 9 Playback Engine options? (buffers, etc)
purely mixing purposes, I mostly record on-site any my mix machine is at my home studio so I take as little as possible and chase the sounds I want at the point of recording.

Havent really messed with the settings too much as it just seems to work no dramas. Im due to start mixing a project soon so I will post my settings then.
#120
7th April 2011
Old 7th April 2011
  #120
Gear Head
 
shortyedwards's Avatar
 

Sonar Home Studio with Liquid Mix?

Would love to hear of any Cakewalk Sonar users who have the LM and how the install goes, how the stability is, etc. I can get one now for the right price ...

Thanks!
-SE
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
Improv / So much gear, so little time!
492
Shaman / Product Alerts older than 2 months
2
sleepyhollos / Gearslutz Secondhand Gear Classifieds
0
pixelhead / Gearslutz Secondhand Gear Classifieds
4

Forum Jump
 
Register FAQ Search Today's Posts Mark Forums Read

SEO by vBSEO ©2011, Crawlability, Inc.