Login / Register
 
Roland FantomS - How to stop the control knobs sending MIDI out?
New Reply
Subscribe
KTlin
Thread Starter
#1
2nd December 2012
Old 2nd December 2012
  #1
Gear interested
 
Joined: Apr 2011
Location: Timisoara, Romania
Posts: 15

Thread Starter
KTlin is offline
Roland FantomS - How to stop the control knobs sending MIDI out?

Hi guys

I thought this would be an easy task, but it seems like it isn't.

So, my problem: I have a Fantom S connected to my laptop, and on the laptop I'm running Steinberg's Halion 4 in stand-alone mode. I use my Fantom to play some instruments from itself but also to play instruments from Halion using the MIDI OUT connection. If I want to modify some instruments on my Fantom using the realtime control knobs, I end up modifying the instruments on Halion as well, because those knobs transmit midi data (CC messages) to Halion. So my question is: how can i stop those knobs to send out MIDI data, and make them controlling only the instruments inside the Fantom?

Cheers
#2
2nd December 2012
Old 2nd December 2012
  #2
Matrix Modulator
 
asynchro_nous's Avatar
 
Joined: Jan 2009
Location: Vibration
Posts: 1,990

asynchro_nous is online now
Have you tried going into System mode and setting Transmit Edit Data to "Off"?
KTlin
Thread Starter
#3
2nd December 2012
Old 2nd December 2012
  #3
Gear interested
 
Joined: Apr 2011
Location: Timisoara, Romania
Posts: 15

Thread Starter
KTlin is offline
Yes. All 5 entries in System Setup>MIDI>Transmit are set to OFF.
#4
2nd December 2012
Old 2nd December 2012
  #4
Matrix Modulator
 
asynchro_nous's Avatar
 
Joined: Jan 2009
Location: Vibration
Posts: 1,990

asynchro_nous is online now
Sounds like you can disable transmission of system exclusive data but not CC data.

Can you set Halion to not receive incoming CC data?
KTlin
Thread Starter
#5
2nd December 2012
Old 2nd December 2012
  #5
Gear interested
 
Joined: Apr 2011
Location: Timisoara, Romania
Posts: 15

Thread Starter
KTlin is offline
I think not. You can only filter the MIDI channel. And I need Halion to receive other CC messages from Fantom (like Hold pedal, modulation, pitchbend). So I must stop somehow those 4 knobs sending MIDI out.
#6
2nd December 2012
Old 2nd December 2012
  #6
Moderator
 
narcoman's Avatar
 
Joined: May 2007
Location: UK
Posts: 11,728

narcoman is offline
nothing in the MIDI filters in the DAW?
KTlin
Thread Starter
#7
2nd December 2012
Old 2nd December 2012
  #7
Gear interested
 
Joined: Apr 2011
Location: Timisoara, Romania
Posts: 15

Thread Starter
KTlin is offline
I could probably get some MIDI filter in Ableton to do the job, but I want to use Halion in standalone mode as well.
KTlin
Thread Starter
#8
4th December 2012
Old 4th December 2012
  #8
Gear interested
 
Joined: Apr 2011
Location: Timisoara, Romania
Posts: 15

Thread Starter
KTlin is offline
If at the beginning I thought this would be an easy task, now I came at the conclusion that it's impossible.

Anyway, thanks for your contribution guys!
New Reply Submit Thread to Facebook Facebook  Submit Thread to Twitter Twitter  Submit Thread to LinkedIn LinkedIn  Submit Thread to Google+ Google+ 
 
Topic:
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
korce / Rap + Hip Hop engineering & production
1
pchc_lx / Electronic Music Instruments & Electronic Music Production
4
AtoM-A / So much gear, so little time!
0
edit machine / Electronic Music Instruments & Electronic Music Production
17
coolcat / Electronic Music Instruments & Electronic Music Production
15

Forum Jump

SEO by vBSEO ©2011, Crawlability, Inc.