Login / Register
 
CUBASE 7: New midi delay-compensation doesn't work!
New Reply
Subscribe
FilmNMusicman
Thread Starter
#1
23rd December 2012
Old 23rd December 2012
  #1
Lives for gear
 
FilmNMusicman's Avatar
 
Joined: Jan 2011
Location: Marz
Posts: 939

Thread Starter
FilmNMusicman is offline
CUBASE 7: New midi delay-compensation doesn't work!

Does anyone enable this and still see a problem with how they're hearing back what is supposed to be now "delay compensated"?

I'm still getting high amounts of delay even with the buffer set to 384 (11ms).

This feature seems to be all wrong, can someone explain?
__________________
SYNTH: Moog Little Phatty/DSI Mopho/DSI Tetra/DSI Evolver/Sequential Circuits MultiTrak/Korg MS2000B

RACK: MR816CSX/Presonus Eureka/PRE73+EQ73/Valley People Dynamite/Ashly CL52E & PQX571/DBX 166A/VLA PRO

PEDALS: Moogerfooger MF102 RingModulator, Way Huge Aqua Puss MKII, Way Huge Green Rhino MKII, EHX Big Muff

http://soundcloud.com/godsons
#2
24th December 2012
Old 24th December 2012
  #2
Lives for gear
 
spiderman's Avatar
 
Joined: Jun 2006
Location: NYC
Posts: 1,386

spiderman is offline
Some plugins cause delay above and beyond your interface buffer settings. Click on the Devices (menu) - Plugin Information. Then look at the latency column. Some plugins like Ozone 5 have a high audio processing latency. If one of these is loaded in your project, it could be part of the problem.

Can't comment on the specific feature.... just throwing out one of my standard "need to check this" operations.
#3
24th December 2012
Old 24th December 2012
  #3
Manic Modulator
 
Red Black's Avatar
 
Joined: Jun 2011
Location: Melbourne
Posts: 715

Red Black is offline
Easiest way to bypass what Spidie mentioned is to hit the 'Constrain Delay Compensation' button. This will temporarily disable any plugs that are delaying the whole project, so it's a great way to quickly record a MIDI or audio part without manually disabling every latency-inducing plug-in in your project.

With that button enabled the only latency you should be experiencing is that induced by your A/D, D/A conversion and by the buffer settings on your audio interface.

Also, if you're working at 44.1 then a buffer size of 384 samples will still induce a noticeable delay.. I prefer a buffer size of 128 samples for playing MIDI parts. Unless you're on a higher sample rate your stated buffer latency of 11ms should actually be about twice that!

I've just started playing around with Studio One and it actually gives you a display of your current project latency as induced by plug-ins which is fantastic! I wish Cubase would incorporate something similar..

Cheers..

RB
#4
24th December 2012
Old 24th December 2012
  #4
Lives for gear
 
4damind's Avatar
 
Joined: Sep 2005
Location: Berlin, Germany
Posts: 1,259
My Recordings/Credits

4damind is offline
Maybe this has something to do in combination with ASIO guard? Afaik the maximal additional latency with ASIO guard is 20ms.
__________________

Frank Arnold
Musician and IT Freelancer

| | |
| |
FilmNMusicman
Thread Starter
#5
24th December 2012
Old 24th December 2012
  #5
Lives for gear
 
FilmNMusicman's Avatar
 
Joined: Jan 2011
Location: Marz
Posts: 939

Thread Starter
FilmNMusicman is offline
It's weird, it's been happening for quite a while but what's up with the MIDI notes always coming in early......WTF, any fix for this problem???
#6
24th December 2012
Old 24th December 2012
  #6
Manic Modulator
 
Red Black's Avatar
 
Joined: Jun 2011
Location: Melbourne
Posts: 715

Red Black is offline
Quote:
Originally Posted by FilmNMusicman View Post
It's weird, it's been happening for quite a while but what's up with the MIDI notes always coming in early......WTF, any fix for this problem???
Could you be more specific?

Is this problem there whether ASIO guard is active or not?

If you mean that after recording MIDI the recorded notes seem to be out of sync with the playback you heard, then try going to into DEVICES > DEVICE SETUP. Go to MIDI > MIDI Port Setup and toggle "Use System Timestamp"

RB
#7
25th December 2012
Old 25th December 2012
  #7
Lives for gear
 
Paul in SoCal's Avatar
 
Joined: Sep 2012
Location: Sunny SoCal
Posts: 685

Paul in SoCal is offline
Quote:
Originally Posted by FilmNMusicman View Post

I'm still getting high amounts of delay even with the buffer set to 384 (11ms).
384 samples is a pretty high buffer. No wonder you get delays... Try 128 and see what happens.
New Reply Submit Thread to Facebook Facebook  Submit Thread to Twitter Twitter  Submit Thread to LinkedIn LinkedIn  Submit Thread to Google+ Google+ 
 
Topic:
Thread Tools
Search this Thread
Search this Thread:

Advanced Search
Similar Threads
Thread
Thread Starter / Forum
Replies
Dimension Zero / Remote Possibilities in Acoustic Music & Location Recording
11
Pronecobra / Music Computers
3
starcrash13 / Post Production forum!
11
fontenele / Music Computers
1
KeengCong / Rap + Hip Hop engineering & production
2

Forum Jump

SEO by vBSEO ©2011, Crawlability, Inc.